Bug 893110 - systemctl is-enabled command need .service suffix for service name
systemctl is-enabled command need .service suffix for service name
Status: CLOSED DUPLICATE of bug 880353
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-08 10:42 EST by Matthieu Saulnier
Modified: 2013-01-08 10:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 10:45:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthieu Saulnier 2013-01-08 10:42:21 EST
Description of problem:

For exemple using bluetoothd service:
[casper@Blackbird ~]$ systemctl status bluetooth
bluetooth.service - Bluetooth service
	  Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled)
	  Active: active (running) since Sun, 2013-01-06 04:21:53 CET; 2 days ago
	Main PID: 977 (bluetoothd)
	  CGroup: name=systemd:/system/bluetooth.service
		  └ 977 /usr/sbin/bluetoothd -n

[casper@Blackbird ~]$ systemctl is-enabled bluetooth
Failed to issue method call: Invalid argument
[casper@Blackbird ~]$ systemctl is-enabled bluetooth.service
enabled


Version-Release number of selected component (if applicable):
systemd-195-15.fc18.x86_64


How reproducible:
Always

  
Actual results:
Doesn't work without .service suffix


Expected results:
Works without .service suffix


Additional info:
Comment 1 Michal Schmidt 2013-01-08 10:45:45 EST

*** This bug has been marked as a duplicate of bug 880353 ***

Note You need to log in before you can comment on or make changes to this bug.