Bug 893573 - [RHEVM] Get error during close SPICE Console windows - Cannot get vdsManager for vdsid=00000000-0000-0000-0000-000000000000
[RHEVM] Get error during close SPICE Console windows - Cannot get vdsManager...
Status: CLOSED DUPLICATE of bug 868297
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.2.0
Assigned To: Roy Golan
vvyazmin@redhat.com
virt
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-09 08:39 EST by vvyazmin@redhat.com
Modified: 2013-02-21 03:08 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:08:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
## Logs rhevm (2.12 MB, application/octet-stream)
2013-01-09 08:39 EST, vvyazmin@redhat.com
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10770 None None None Never

  None (edit)
Description vvyazmin@redhat.com 2013-01-09 08:39:50 EST
Created attachment 675550 [details]
## Logs rhevm

Description of problem:
Get error during close SPICE Console windows

Version-Release number of selected component (if applicable):
RHEVM 3.2 - SF03 environment 

RHEVM: rhevm-3.2.0-4.el6ev.noarch
VDSM: vdsm-4.10.2-3.0.el6ev.x86_64
LIBVIRT: libvirt-0.10.2-13.el6.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.348.el6.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Open SPICE Console windows
2. Close SPICE Console windows
  
Actual results:
In /var/log/ovirt-engine/engine.log get error:
Cannot get vdsManager for vdsid=00000000-0000-0000-0000-000000000000

Expected results:
No exception should be found

Additional info:

/var/log/ovirt-engine/engine.log
2013-01-09 17:22:11,504 WARN  [org.ovirt.engine.core.dal.job.ExecutionMessageDirector] (ajp-/127.0.0.1:8702-4) [7eee8509] The message key UpdateVmConsoleData is missing from bundles/ExecutionMessages
2013-01-09 17:22:11,616 INFO  [org.ovirt.engine.core.bll.UpdateVmConsoleDataCommand] (ajp-/127.0.0.1:8702-4) [7eee8509] Running command: UpdateVmConsoleDataCommand internal: false. Entities affected :  ID: 509916a2-0be4-480c-8c9a-a2427c74f0a2 Type: VM
2013-01-09 17:22:11,616 ERROR [org.ovirt.engine.core.vdsbroker.ResourceManager] (ajp-/127.0.0.1:8702-4) [7eee8509] Cannot get vdsManager for vdsid=00000000-0000-0000-0000-000000000000
2013-01-09 17:22:11,618 INFO  [org.ovirt.engine.core.vdsbroker.UpdateVmDynamicDataVDSCommand] (ajp-/127.0.0.1:8702-4) [7eee8509] START, UpdateVmDynamicDataVDSCommand( HostId = 00000000-0000-0000-0000-000000000000, vmDynamic=org.ovirt.engine.core.common.businessentities.VmDynamic@99145e55), log id: 50eed693
2013-01-09 17:22:11,618 INFO  [org.ovirt.engine.core.vdsbroker.UpdateVmDynamicDataVDSCommand] (ajp-/127.0.0.1:8702-4) [7eee8509] FINISH, UpdateVmDynamicDataVDSCommand, log id: 50eed693


/var/log/vdsm/vdsm.log
Comment 4 Roy Golan 2013-02-10 04:14:28 EST
depends on 868297

The UpdateVmConsoleData command has been removed since the console data is being updated by vds monitoring.

Note You need to log in before you can comment on or make changes to this bug.