Bug 868297 - [ Strict User Checking] No warning to admin before he takes over user console which in turn forces a VM reboot for the user to reconnect
[ Strict User Checking] No warning to admin before he takes over user console...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.2.0
Assigned To: Frantisek Kobzik
Pavel Stehlik
virt
: Regression
: 868361 868363 893573 (view as bug list)
Depends On:
Blocks: 915537
  Show dependency treegraph
 
Reported: 2012-10-19 08:44 EDT by David Jaša
Modified: 2013-06-11 05:54 EDT (History)
11 users (show)

See Also:
Fixed In Version: sf8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 10770 None None None Never

  None (edit)
Description David Jaša 2012-10-19 08:44:38 EDT
Description of problem:
Warn admin before takes over user console if the user is connected or logged in and Strict User Checking is set.

This may be potentially destructive, because admin has no way to allow the user to be able to reconnect again before VM shutdown - and user is in risk of data loss because he isn't able to save his work.

IMNSHO the warning should be issued if any of these conditions are set:
  * regular user who won't be able to reconnect is connected (has VM ticket)
  * regular user who won't be able to reconnect is logged-in
    (reported by RHEV agent)


Version-Release number of selected component (if applicable):
3.1.0-18 / si19.1

How reproducible:
always

Steps to Reproduce:
1. connect with UserRole use to a VM
2. connect to the same VM as a pure admin user from webadmin
3. 
  
Actual results:
* no warning
* no way for user to reconnect to the console

Expected results:
* admin has big fat warning if any of the conditions above is met

Additional info:
Comment 1 David Jaša 2012-10-19 11:22:10 EDT
if bug 868361 and bug 868361 are implemented, this one can be safely closed as WONTFIX.
Comment 2 Simon Grinberg 2012-10-21 13:53:26 EDT
(In reply to comment #1)
> if bug 868361 and bug 868361 are implemented, this one can be safely closed
> as WONTFIX.

David, what you are trying to do here with these 3 bugs is to re-desing a gap in the design of the feature to block reconnect. The suggestions are very good but it's not the way to do it. 

I'm renaming this bug to what it is, closing the other two on DUPs for now and consolidating them into suggested solution, if required we'll reopen the other as steps to implementation. 

Changing summary from:
"Warn admin before takes over user console if the user is connected or logged in and Strict User Checking is set" to whatever is now up there
Comment 3 Simon Grinberg 2012-10-21 13:53:58 EDT
*** Bug 868361 has been marked as a duplicate of this bug. ***
Comment 4 Simon Grinberg 2012-10-21 13:55:01 EDT
*** Bug 868363 has been marked as a duplicate of this bug. ***
Comment 5 Simon Grinberg 2012-10-21 14:01:47 EDT
The short term solution suggested here is to provide a warning to the user, the ack is for this. This warning must be given since users may look at this as a regression compared to 3.0.


Long term (3.2?) should probably as suggested in: 
Bug 868363 - strict user checking: if admin takes over VM console, remember last logged in user and allow admin to allow the user to reconnect again, and in Bug 868361 - strict user checking: in webadmin, highlight VMs where none of their regular users can log in because they were taken over by admin. Though highlight may be replaced with update icon to indicate this state.
Comment 12 Frantisek Kobzik 2013-01-09 07:55:29 EST
In gerrit: http://gerrit.ovirt.org/#/c/10770/
Comment 13 Roy Golan 2013-02-21 03:08:00 EST
*** Bug 893573 has been marked as a duplicate of this bug. ***
Comment 14 Oded Ramraz 2013-03-05 03:38:46 EST
Tested with sf9:

When I first login from user portal and then login to same VM from webadmin the login succeed . 

When I first login from webadmin and then trying to login to the same VM from user portal I get the following error : 
"Console connection denied. Another user has already accessed the console of this VM. The VM should be rebooted to allow another user to access it, or changed by an admin to not enforce reboot between users accessing its console."
Comment 15 Oded Ramraz 2013-03-05 08:46:47 EST
Apparently I didn't wait enough time to the user session to update in DB . 
After retesting first use case and wait more time I got this message : 
"There may be users connected to the console who will not be able to reconnect. Do you want to proceed?"
Moving the bug to verified 

BTW I noticed that after the admin disconnect its Spice session the user still can't login to its VM. I'll open separate busy for this issue .
Comment 16 Itamar Heim 2013-06-11 05:42:53 EDT
3.2 has been released
Comment 17 Itamar Heim 2013-06-11 05:42:54 EDT
3.2 has been released
Comment 18 Itamar Heim 2013-06-11 05:54:41 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.