Bug 894242 - upgrade process hangs with encrypted /home (no graphical unlock dialog)
upgrade process hangs with encrypted /home (no graphical unlock dialog)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup-dracut (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
: 904156 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-11 02:12 EST by Jens Petersen
Modified: 2013-06-23 01:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: fedup-0.7.3-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 23:29:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2013-01-11 02:12:25 EST
Description of problem:
Upgrading from F17 to F18 with an encrypted home partition
seems to cause upgrade process with plymouth to crash early on.

Version-Release number of selected component (if applicable):
fedup-0.7.2-1.fc17
plymouth-0.8.8-5.fc18

How reproducible:
100%

Steps to Reproduce:
1. install latest F17 with encrypted /home partition
2. fedup --network 18 --instrepo .../development/18/x86_64/os --reboot
3. watch upgrade process
  
Actual results:
Fedup Plymouth GUI appears but disappears after a couple of seconds
and before asking for /home passphrase.
After longer time it finally boots back to F17 gdm login.

Expected results:
Upgrade not to crash.

Fedup+plymouth might still have some rough edge cases
so at least for this it might be better to default to
text upgrade instead of graphical.

Additional info:
I think this did not happen with F18-Beta upgrade image
so this might be a regression.

Workaround is to remove rhgb from fedup kernel line and
do upgrade in text mode which works fine.  But that might
prevent fedup from updating grub.cfg correctly after upgrade?
Comment 1 Tim Flink 2013-01-11 02:15:01 EST
This sounds more like an issue with fedup-dracut, reassigning.

the grub upgrade/update process is not covered by fedup and has to be done manually, so any changes during the upgrade process won't affect the grub.cfg post-upgrade
Comment 2 Jens Petersen 2013-01-16 21:37:01 EST
Here is the original http://petersen.fedorapeople.org/fedupdebug.log
from my main machine so it is not a "vanilla" but a realworld upgrade.

> the grub upgrade/update process is not covered by fedup and has to be done
> manually, so any changes during the upgrade process won't affect the
> grub.cfg post-upgrade

Okay I confirmed that modifying the kernel line does not break
removal of Upgrade from grub.cfg if a new kernel gets installed
at least - maybe my problem was that there was no newer f18 kernel
when I upgraded before F18 GA.
Comment 3 Will Woods 2013-01-23 22:09:56 EST
Did you have any other encrypted partitions, or just /home?
Comment 4 Jens Petersen 2013-01-24 01:28:48 EST
(In reply to comment #3)
> Did you have any other encrypted partitions, or just /home?

Just /home
Comment 5 Will Woods 2013-02-14 14:07:14 EST
I think might be the same problem as bug 896023.

If so, you should be able to work around this by removing "rhgb" *and* "plymouth.splash=fedup" from the fedup boot arguments.

I tested this myself and it seems to work. Can anyone else confirm?
Comment 6 Jens Petersen 2013-02-14 23:34:53 EST
(In reply to comment #5)
> If so, you should be able to work around this by removing "rhgb" *and*
> "plymouth.splash=fedup" from the fedup boot arguments.

I and others already mentioned about rhgb.
Can you explain why also removing "plymouth.splash=fedup" helps?
Comment 7 Jens Petersen 2013-02-14 23:50:06 EST
Anyway it does sound like a related bug, though it is not entirely clear
to me why crypto /home should break things more.


I still contend that while using Plymouth for upgrades looks pretty,
the text console output is actually more informative and more importantly
reliable it seems.

Well I guess if one could toggle between them both that would be perfect. :)
Comment 8 Jens Petersen 2013-02-19 03:43:18 EST
I just did a test with upgrading a minimal+rhgb f17 net install
without "rhgb" and "plymouth.splash=fedup" and indeed it worked
fine as expected (though I already mentioned the no rhgb workaround
in comment 0).
Comment 9 Fedora Update System 2013-04-30 10:51:19 EDT
fedup-0.7.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.7.3-3.fc18
Comment 10 Fedora Update System 2013-04-30 10:55:11 EDT
fedup-0.7.3-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-3.fc17
Comment 11 Fedora Update System 2013-04-30 11:37:37 EDT
fedup-0.7.3-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-4.fc17
Comment 12 Fedora Update System 2013-04-30 11:38:17 EDT
fedup-0.7.3-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.7.3-4.fc18
Comment 13 Fedora Update System 2013-04-30 11:39:30 EDT
fedup-0.7.3-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.7.3-4.fc19
Comment 14 Will Woods 2013-04-30 14:17:08 EDT
*** Bug 904156 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2013-04-30 16:09:37 EDT
Package fedup-0.7.3-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.7.3-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-7092/fedup-0.7.3-4.fc19
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-05-14 23:29:54 EDT
fedup-0.7.3-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-06-07 12:43:14 EDT
fedup-0.7.3-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedup-0.7.3-5.fc17
Comment 18 Fedora Update System 2013-06-07 23:34:38 EDT
fedup-0.7.3-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2013-06-23 01:56:33 EDT
fedup-0.7.3-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.