Bug 904156 - upgrade F17 -> F18 does not work when using encrypted LVM disk without saved phrase.
upgrade F17 -> F18 does not work when using encrypted LVM disk without saved ...
Status: CLOSED DUPLICATE of bug 894242
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-25 10:43 EST by Tomáš Hozza
Modified: 2013-04-30 14:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-30 14:17:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomáš Hozza 2013-01-25 10:43:31 EST
Description of problem:
I was upgrading my Fedora 17 to 18 today using FedUp. I followed every step on
FedUp wiki page (https://fedoraproject.org/wiki/FedUp#How_Can_I_Upgrade_My_System_with_FedUp.3F).
After FedUp downloaded all packages I rebooted the system. Then selected the 
"System upgrade" GRUB entry. I hit ESC to see detailed information. The process
stopped on mounting my /home directory, for which I use LVM partition encrypted
using luks. The encryption phrase needs to be entered (is not saved on the disk).
Unfortunately the prompt (asking me for the phrase) was not responding to my
notebook keyboard nor to my external keyboard connected through USB. I had to wait
around 30 sec. until the process time-outs. After this emergency shell showed up.

Version-Release number of selected component (if applicable):
fedup-0.7.1-1.fc18

How reproducible:
Tried only once

Steps to Reproduce:
1. Setup Fedora 17 system with encrypted LVM partition mounted on boot in /home.
Your system have to be configured to ask you the phrase on boot for this partition.
2. Upgrade your system using FedUp to Fedora 18 (https://fedoraproject.org/wiki/FedUp#How_Can_I_Upgrade_My_System_with_FedUp.3F)
  
Actual results:
After FedUp downloaded all packages and rebooting the system I was unable to
enter encryption phrase for my encrypted LVM partition and could not proceed
with the system upgrade.

Expected results:
After FedUp downloaded all packages and rebooting the system I should be able
to enter encryption phrase for my encrypted LVM partition and proceed with
the system upgrade.

Additional info:
I had to setup auto unlocking the encrypted LVM partition to proceed with the upgrade.

1. echo "password" > /root/luksPass
2. chmod 600 /root/luksPass
3. cryptsetup luksAddKey <path to LVM partition> /root/luksPass
4. modify /etc/crypttab to use password from /root/luksPass
5. reboot
6. proceed with the system upgrade
Comment 1 Aissen 2013-04-29 07:54:04 EDT
I had the same problem when trying the upgrade from F18 to F19.
Comment 2 Will Woods 2013-04-30 10:50:35 EDT
This is probably the same problem as bug 894242.

Does it work if you use fedup-0.7.3 (in updates-testing)?
Comment 3 Tomáš Hozza 2013-04-30 11:16:24 EDT
I'm sorry, but I have no way how to test it, except setting up a VM just for
testing. But you can try to add this Bug to the update in Bodhi and let other
people test it (if you think it should be fixed in that update).
Comment 4 Will Woods 2013-04-30 14:17:08 EDT
If you have no way of testing it, then I can only assume this is the same problem found on other systems with encrypted /home, so I'm closing it as a duplicate.

*** This bug has been marked as a duplicate of bug 894242 ***

Note You need to log in before you can comment on or make changes to this bug.