Bug 894281 - evolution-calender-factory was killed by signal 6(SIGABRT)
Summary: evolution-calender-factory was killed by signal 6(SIGABRT)
Keywords:
Status: CLOSED DUPLICATE of bug 903045
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 18
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-11 09:52 UTC by Samarjit Adhikari
Modified: 2013-01-29 09:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-29 09:44:51 UTC
Type: Bug


Attachments (Terms of Use)
evolutiion-dataserver-crash-file (27.86 KB, application/octet-stream)
2013-01-14 16:26 UTC, Samarjit Adhikari
no flags Details
ubuntu_eds-calendar_factory_crash (2.64 MB, application/zip)
2013-01-29 07:24 UTC, Samarjit Adhikari
no flags Details

Description Samarjit Adhikari 2013-01-11 09:52:31 UTC
Description of problem:
Suddenly evolution-data-server was crashed by signal 6

Version-Release number of selected component (if applicable):
fedora-18-prerelease
Evolution3.6.2

How reproducible:
Not known

Steps to Reproduce:
1. N/A
2.
3.
  
Actual results:
evolution-data-server crash

Expected results:
should not crash

Additional info:
Automatic bug reporting tool was failed to collect data.
I attached gdb with evolution-data-server and keeps on running.
When crashed, collected info

Comment 1 Milan Crha 2013-01-14 14:32:04 UTC
Thanks for a bug report. It seems to me you forgot to attach the backtrace :)

Comment 2 Samarjit Adhikari 2013-01-14 16:26:02 UTC
Created attachment 678291 [details]
evolutiion-dataserver-crash-file

Comment 3 Samarjit Adhikari 2013-01-14 16:26:52 UTC
(In reply to comment #1)
> Thanks for a bug report. It seems to me you forgot to attach the backtrace :)

Sorry, added attachment now.

Comment 4 Milan Crha 2013-01-14 19:27:42 UTC
Thanks for the update. I do not see a crash in the attached file (you can use "t a a bt" to get backtrace with all threads). The all threads you listed are basically idle, waiting for orders, and the gdb was stopped with Ctrl+C. Can it be that it didn't crash this time?

Comment 5 Samarjit Adhikari 2013-01-15 07:02:28 UTC
(In reply to comment #4)
> Thanks for the update. I do not see a crash in the attached file (you can
> use "t a a bt" to get backtrace with all threads). The all threads you
> listed are basically idle, waiting for orders, and the gdb was stopped with
> Ctrl+C. Can it be that it didn't crash this time?

hum, automatic bug reporting tool suddenly informed that data server has crashed. Then o do Ctrl-C and took all traces. lets wait for few days to check if it crash again. Today i have updated to evolution-data-server 3.6.2-3. Lets see, if it crash after that.

===============================================================================================================
 Package                                 Arch               Version                  Repository           Size
===============================================================================================================
Updating:
 evolution-data-server                   x86_64             3.6.2-3.fc18             updates             3.2 M
 evolution-data-server-devel             x86_64             3.6.2-3.fc18             updates             316 k

Transaction Summary
===============================================================================================================
Upgrade  2 Packages

Total download size: 3.5 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
updates/prestodelta                                                                     | 807 kB  00:00:04 !!! 
Processing delta metadata
Download delta size: 292 k
(1/2): evolution-data-server-devel-3.6.2-2.fc18_3.6.2-3.fc18.x86_64.drpm                |  92 kB  00:00:02     
(2/2): evolution-data-server-3.6.2-2.fc18_3.6.2-3.fc18.x86_64.drpm                      | 200 kB  00:00:05     
Finishing rebuild of rpms, from deltarpms
<locally rebuilding deltarpms>                                                          | 3.5 MB  00:00:03     
Presto reduced the update size by 92% (from 3.5 M to 292 k).
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : evolution-data-server-3.6.2-3.fc18.x86_64                                                   1/4 
  Updating   : evolution-data-server-devel-3.6.2-3.fc18.x86_64                                             2/4 
  Cleanup    : evolution-data-server-devel-3.6.2-2.fc18.x86_64                                             3/4 
  Cleanup    : evolution-data-server-3.6.2-2.fc18.x86_64                                                   4/4 
  Verifying  : evolution-data-server-devel-3.6.2-3.fc18.x86_64                                             1/4 
  Verifying  : evolution-data-server-3.6.2-3.fc18.x86_64                                                   2/4 
  Verifying  : evolution-data-server-devel-3.6.2-2.fc18.x86_64                                             3/4 
  Verifying  : evolution-data-server-3.6.2-2.fc18.x86_64                                                   4/4 

Updated:
  evolution-data-server.x86_64 0:3.6.2-3.fc18         evolution-data-server-devel.x86_64 0:3.6.2-3.fc18

Comment 6 Milan Crha 2013-01-15 09:15:03 UTC
Package evolution-data-server provides multiple binaries, it's evolution-addressbook-factory, evolution-calendar-factory and evolution-source-registry. When anyone of these crashes, the ABRT will always claim evolution-data-server package, but also name in which process the crash happened.

Comment 7 Samarjit Adhikari 2013-01-29 07:21:44 UTC
--------------------------------------------------------------------------------
I am reopening this bug as i have found similar crash in e-d-s with 
evolution-calender-factory while using mapi. This time with evolution-ubuntu-package.
--------------------------------------------------------------------------------
File attached.

Comment 8 Samarjit Adhikari 2013-01-29 07:24:29 UTC
Created attachment 689603 [details]
ubuntu_eds-calendar_factory_crash

Comment 9 Milan Crha 2013-01-29 09:44:51 UTC
I'm sorry, but Ubuntu has their own bugzilla, which can pretty well decipher the crash report (your backtrace doesn't contain any debug information, for example, while their bugzilla can replace these with useful information). Fedora and Ubuntu meets in the evolution's upstream bugzilla, which is http://bugzilla.gnome.org . Nonetheless, if I would guess, then I think this is related to [1], thus I'm marking this as a duplicate of the original downstream Fedora bug report.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=692371

*** This bug has been marked as a duplicate of bug 903045 ***


Note You need to log in before you can comment on or make changes to this bug.