Bug 903045 - [abrt] evolution-data-server-3.6.2-3.fc18: tdb_nest_lock: Process /usr/libexec/evolution-calendar-factory was killed by signal 6 (SIGABRT)
Summary: [abrt] evolution-data-server-3.6.2-3.fc18: tdb_nest_lock: Process /usr/libexe...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:fb36543146e50fa7db4f657c1ef...
: 894281 903957 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-23 01:30 UTC by Nathan Crubel
Modified: 2013-02-20 03:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-23 10:50:45 UTC


Attachments (Terms of Use)
File: backtrace (81.70 KB, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: cgroup (131 bytes, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: core_backtrace (6.50 KB, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: dso_list (23.07 KB, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: environ (758 bytes, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: maps (110.85 KB, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: open_fds (1.33 KB, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: proc_pid_status (931 bytes, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details
File: smolt_data (3.99 KB, text/plain)
2013-01-23 01:31 UTC, Nathan Crubel
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 692371 None None None Never

Description Nathan Crubel 2013-01-23 01:30:51 UTC
Description of problem:
Started up evolution and let it sync with exchange.  

Version-Release number of selected component:
evolution-data-server-3.6.2-3.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: tdb_nest_lock
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.7.2-204.fc18.x86_64
remote_result:  NOTFOUND
uid:            1001
var_log_messages: Jan 22 19:20:53 ncantec abrt[26518]: Saved core dump of pid 25970 (/usr/libexec/evolution-calendar-factory) to /var/spool/abrt/ccpp-2013-01-22-19:20:36-25970 (886140928 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #6 tdb_nest_lock at ../common/lock.c:281
 #8 tdb_lock_list at ../common/lock.c:355
 #9 tdb_lock at ../common/lock.c:374
 #10 tdb_find_lock_hash at ../common/tdb.c:118
 #11 tdb_parse_record at ../common/tdb.c:245
 #12 ltdb_search_dn1 at ../ldb_tdb/ldb_search.c:286
 #13 ltdb_cache_load at ../ldb_tdb/ldb_cache.c:344
 #14 ltdb_connect at ../ldb_tdb/ldb_tdb.c:1577
 #15 ldb_module_connect_backend at ../common/ldb_modules.c:217
 #16 ldb_connect at ../common/ldb.c:251

Comment 1 Nathan Crubel 2013-01-23 01:31:09 UTC
Created attachment 685551 [details]
File: backtrace

Comment 2 Nathan Crubel 2013-01-23 01:31:11 UTC
Created attachment 685552 [details]
File: cgroup

Comment 3 Nathan Crubel 2013-01-23 01:31:15 UTC
Created attachment 685553 [details]
File: core_backtrace

Comment 4 Nathan Crubel 2013-01-23 01:31:19 UTC
Created attachment 685554 [details]
File: dso_list

Comment 5 Nathan Crubel 2013-01-23 01:31:23 UTC
Created attachment 685555 [details]
File: environ

Comment 6 Nathan Crubel 2013-01-23 01:31:26 UTC
Created attachment 685556 [details]
File: limits

Comment 7 Nathan Crubel 2013-01-23 01:31:29 UTC
Created attachment 685557 [details]
File: maps

Comment 8 Nathan Crubel 2013-01-23 01:31:32 UTC
Created attachment 685558 [details]
File: open_fds

Comment 9 Nathan Crubel 2013-01-23 01:31:34 UTC
Created attachment 685559 [details]
File: proc_pid_status

Comment 10 Nathan Crubel 2013-01-23 01:31:37 UTC
Created attachment 685560 [details]
File: smolt_data

Comment 11 Milan Crha 2013-01-23 10:50:45 UTC
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=692371

Comment 12 Milan Crha 2013-01-25 17:59:24 UTC
*** Bug 903957 has been marked as a duplicate of this bug. ***

Comment 13 Milan Crha 2013-01-25 18:14:52 UTC
I built a scratch-build with the upstream patch included, it is available at [1]. Once the 3.6.3 update is in stable I'll roll out the evolution-mapi-3.6.3-2.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=4902933

Comment 14 Nathan Crubel 2013-01-28 18:21:37 UTC
Thanks

Comment 15 Milan Crha 2013-01-29 09:44:51 UTC
*** Bug 894281 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2013-02-04 12:47:06 UTC
evolution-mapi-3.6.3-2.fc18,evolution-data-server-3.6.3-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/evolution-mapi-3.6.3-2.fc18,evolution-data-server-3.6.3-2.fc18

Comment 17 Fedora Update System 2013-02-20 03:57:40 UTC
evolution-mapi-3.6.3-2.fc18, evolution-data-server-3.6.3-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.