Bug 894290 - Boinc included non-free files.
Boinc included non-free files.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: boinc-client (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Milos Jakubicek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-01-11 05:42 EST by mejiko
Modified: 2013-01-15 07:26 EST (History)
3 users (show)

See Also:
Fixed In Version: boinc-client-7.0.44-1.git443c49949.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-15 07:26:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 131997 None None None Never
Debian BTS 564474 None None None Never
GNU Savannah 28528 None None None Never

  None (edit)
Description mejiko 2013-01-11 05:42:17 EST
Hello.

boinc-client included non-free files.


Files:

boinc_core_release_7_0a/samples/glut/glut.h
boinc_core_release_7_0a/samples/glut/glut_roman.c
boinc_core_release_7_0a/samples/glut/glut_stroke.c
boinc_core_release_7_0a/samples/glut/glut_swidth.c
boinc_core_release_7_0a/samples/glut/glutbitmap.h
boinc_core_release_7_0a/samples/samples/glut/glutint.h
boinc_core_release_7_0a/samples/glut/glutstroke.h
boinc_core_release_7_0a/samples/glut/glutwin32.h
boinc_core_release_7_0a/samples/glut/win32_glx.c
boinc_core_release_7_0a/samples/glut/win32_glx.h
boinc_core_release_7_0a/samples/glut/win32_util.c
boinc_core_release_7_0a/samples/glut/win32_x11.c
boinc_core_release_7_0a/samples/glut/win32_x11.h
boinc_core_release_7_0a/api/texfont.cpp
boinc_core_release_7_0a/api/texfont.h

This code license is redistributable, but not allow modify.
because "Allowing modify" statement (example: "You may modify and distribute modify version" etc...) is not find.

Its non-free.

And, This is not "firmware" and "content", This is "code".

case example:

https://bugzilla.redhat.com/show_bug.cgi?id=892925




Seggests:

1. Remove non-free code and rebuild.
2. Replace to Fedora-free (Fedora acceptable licensed code) files.  
3. Remove Fedora repos.


Thanks.

Reference:

http://libreplanet.org/wiki/List_of_software_that_does_not_respect_the_Free_System_Distribution_Guidelines#boinc_.2F_boinc-app-seti
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Binary_Firmware
https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#CodeVsContent
Comment 1 mejiko 2013-01-11 05:44:02 EST
Blocking FE-Legal, This is license problem.
Comment 2 Milos Jakubicek 2013-01-15 07:26:09 EST
Dear Mejiko,

thanks for the report, I have removed those files from the sources (some of them have been already removed by the upstream in the meanwhile) and built http://koji.fedoraproject.org/koji/taskinfo?taskID=4869842.

Thanks,
Milos

Note You need to log in before you can comment on or make changes to this bug.