Bug 89472 - Installer detects DVI port but uses VGA port
Summary: Installer detects DVI port but uses VGA port
Status: CLOSED DUPLICATE of bug 88360
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-23 08:42 UTC by Per Steinar Iversen
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Per Steinar Iversen 2003-04-23 08:42:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
When installing on a machine with an nVidia GeForce4 Ti 4400 graphics card with
both VGA and DVI ports the installer correctly detected that the monitor was
connected to the DVI port. The graphics install however started on the VGA port.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start install
2. See that the installer detects that the monitor is on the DVI port
3. The installer enters graphics mode, but with output on the ordinary VGA port
    

Actual Results:  Had to find a VGA monitor cable.

Expected Results:  Install should have used the DVI port.

Additional info:

Comment 1 Michael Fulbright 2003-04-23 18:54:05 UTC
Mike is there anything we have to do in the XF86Config to have the output come
on the alternate controller?

The probe succeeded because we use the video BIOS.

Comment 2 Mike A. Harris 2003-04-23 22:19:09 UTC
I've no DVI panel hardware and no experience configuring or using XFree86 on
LCD panels, so I'm afraid I can't really give an informed answer.  ;o/

What I can however say for sure, is that the "nv" driver DVI support is
experimental only and not something Red Hat "supports" other than that
we ship it because it is in XFree86.  The DVI support there is known to
have problems, and unfortunately for both us, and for Nvidia hardware
owners using the "nv" driver, only Nvidia can really fix the driver
problems.

All I can do is refer people to the "nv" manpage, and to XFree86.org
bugzilla for Nvidia to be able to investigate driver specific problems
and queries, and fix and/or recommend workarounds.

I do really need to be sent a flat panel display some time soon however
if I'm expected to even be able to remotely try to investigate LCD panel
related problems.

Comment 3 Mike A. Harris 2003-04-23 22:20:45 UTC
Don't know if this is the answer or not, but from the "nv" driver manpage:

       Option "CrtcNumber" "integer"
              nForce2, Quadro4, GeForce4 and NV30 may have two video  outputs.
              The  driver attempts to autodetect which one the monitor is con-
              nected to.  In the case that autodetection picks the wrong  one,
              this  option  may be used to force usage of a particular output.
              The options are "0" or "1".  Default: autodetected.
 
       Option "FlatPanel" "boolean"
              The driver usually cannot autodetect  the  presence  of  a  flat
              panel  so this option should be set when used with a flat panel.
              With this driver a flat panel will only work if it was POSTed by
              the  BIOS,  that  is, the machine must have booted to the panel.
              Default: off.

msf, does this help?

Comment 4 Mike A. Harris 2003-09-27 01:02:07 UTC

*** This bug has been marked as a duplicate of 88360 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:52:47 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.