Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 894778 - [RFE] Add metering/monitoring support (via Ceilometer) to Horizon
[RFE] Add metering/monitoring support (via Ceilometer) to Horizon
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.0 (Folsom)
All Linux
high Severity medium
: Upstream M3
: 4.0
Assigned To: Ladislav Smola
Kevin Whitney
https://blueprints.launchpad.net/hori...
: FutureFeature, OtherQA
Depends On: 988515 996347
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-01-13 14:08 EST by Perry Myers
Modified: 2014-02-02 17:40 EST (History)
11 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-7.el6ost
Doc Type: Enhancement
Doc Text:
Metering resource usage graphs are now available in Dashboard. A new 'Resource Usage' panel is accessible in the Admin dashboard, enabling administrators to query and visualise Metering telemetry data.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 18:56:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stats graph: Black rectangle (45.57 KB, image/png)
2013-11-29 10:18 EST, Julie Pichon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 35588 None None None Never
OpenStack gerrit 35589 None None None Never
OpenStack gerrit 35590 None None None Never
OpenStack gerrit 44289 None None None Never
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Perry Myers 2013-01-13 14:08:21 EST
Add metering/monitoring support (via Ceilometer) to Horizon
Comment 1 Julie Pichon 2013-01-23 11:15:58 EST
See also https://blueprints.launchpad.net/ceilometer/+spec/horizon-plugin for an initial upstream effort at integrating Ceilometer with Horizon.
Comment 3 Julie Pichon 2013-08-14 03:53:52 EDT
Hello. What's the information request for?
Comment 5 Ladislav Smola 2013-09-04 07:11:54 EDT
The basic ceilometer integration (for Havana) consists from 3 blueprints:
https://blueprints.launchpad.net/horizon/+spec/ceilometer
https://blueprints.launchpad.net/horizon/+spec/horizon-chart.js
https://blueprints.launchpad.net/horizon/+spec/admin-resource-usage-page

Prerequisites to test:
Install OpenStack with Ceilometer enabled.

What changed:
On Admin panel you should now see the Resource Usage page with:
1. Several tables with avg statistics of important meters from the last 30 days
2. General multi-line chart showing statistics in time. 
- You can pick meter, whether to group by project or see the resources and time span 
- Know that if there is not enough data, chart resize itself by available data. So having only data from one day, switching to week timespan does nothing.
- The list of all meters is here http://docs.openstack.org/developer/ceilometer/measurements.html (you need to have associated services to see the statistics data)
- Line chart should resize itself to fill the rest of the screen (there is minimal size) and react to window resize event.
Comment 7 Ladislav Smola 2013-09-06 10:55:45 EDT
FYI not sure if the 5 minutes test run will be enough. I think the period of sampling is pretty big (I would say minutes). 
Also for charts, the smallest interval is one day for now, and the chart shows only 400 samples for one line, divided into one day.
Comment 10 Ami Jeain 2013-10-27 09:25:19 EDT
as Perry agreed, it will be tested in upstream tempest.
Comment 11 Julie Pichon 2013-11-28 11:00:16 EST
I'm trying to sanity test this feature, however at the moment the 'Resource Usage' Stats tab only shows a black rectangle (cf. screenshot). Thanks to Ladislav, we determined that it's probable a css file is missing from the compressed CSS - openstack_dashboard/static/dashboard/less/horizon_charts.less as the chart classes don't seem to be included. Matthias, can you help us shed some light on this?
Comment 12 Julie Pichon 2013-11-28 11:23:12 EST
An additional data point: when I removed openstack-dashboard-theme in order to sanity check bug 911888, the Stats graphs started displaying just fine.
Comment 13 Julie Pichon 2013-11-29 10:18:39 EST
Created attachment 830697 [details]
Stats graph: Black rectangle
Comment 18 errata-xmlrpc 2013-12-19 18:56:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.