Bug 988515 - [Doc] [RFE] Add metering/monitoring support (via Ceilometer) to Horizon - DOC: Metering Conceptual Explanation/Introduction
[Doc] [RFE] Add metering/monitoring support (via Ceilometer) to Horizon - DOC...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Administration_User_Guide (Show other bugs)
4.0
Unspecified Unspecified
high Severity medium
: ---
: 4.0
Assigned To: Summer Long
ecs-bugs
https://blueprints.launchpad.net/hori...
: Documentation, FutureFeature, Triaged
: 996347 (view as bug list)
Depends On:
Blocks: 894778 996347 1011085
  Show dependency treegraph
 
Reported: 2013-07-25 14:26 EDT by Stephen Gordon
Modified: 2014-01-09 18:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 996347 (view as bug list)
Environment:
Last Closed: 2014-01-05 22:37:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-07-25 14:26:21 EDT
Cloned for documentation impact, refer to Bug # 894778 for implementation details.
Comment 2 Summer Long 2013-08-12 22:43:18 EDT
The work is very much still in progress, will need to wait to get dev info and install.
Comment 3 Summer Long 2013-10-16 03:03:43 EDT
Hi Ladislav, The basic metering commands are now in the End User guide. Can you confirm that there are no admin-only commands that should be doc'd? thanks, Summer
Comment 4 Ladislav Smola 2013-10-16 09:14:25 EDT
Could you post here a link to the End User guide please? I will check it out.
Comment 5 Summer Long 2013-10-16 19:32:33 EDT
Hi Ladislav, the metering commands in the End User guide are here: http://docs.openstack.org/user-guide/content/ceilometer_cli_commands.html

thanks :) Summer
Comment 6 Ladislav Smola 2013-10-17 04:30:52 EDT
Seems great. As far as I know, there are no admin only commands. It's driven by having rights to resources. So you can always run the command, but without rights to resources, you won't see anything.


Btw. the last thing added to Havana was the Alarm History, but I guess it's not yet in the Ceilometer docs. It was done by eglynn: https://blueprints.launchpad.net/ceilometer/+spec/alarm-audit-api


And there is also a section in Horizon(done in H3) that shows the Ceilometer statistics, so I guess it's not available only via CLI. :-) We call it Resource Usage Page, available only for admins for H3.

Hope it helps. :-) Ladislav
Comment 7 Summer Long 2013-10-25 01:08:17 EDT
Changes made, waiting for review.
Comment 8 Summer Long 2013-10-25 01:10:29 EDT
*** Bug 996347 has been marked as a duplicate of this bug. ***
Comment 9 Summer Long 2013-10-29 00:03:08 EDT
Ladislav has ok'd the changes, waiting for Bruce's review.
Comment 10 Summer Long 2013-10-30 20:11:31 EDT
Updated with Bruce's comments; changes merged. Waiting for brewed package to send to QA.
Comment 13 Summer Long 2013-12-15 18:47:10 EST
Typo fixed; waiting for test-server package before moving over to QE.
Comment 16 Summer Long 2014-01-09 18:34:45 EST
Added https://bugs.launchpad.net/openstack-manuals/+bug/1267638 upstream to backport.

Note You need to log in before you can comment on or make changes to this bug.