Bug 894783 - Add migrate operation support to Horizon
Add migrate operation support to Horizon
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
2.0 (Folsom)
All Linux
medium Severity medium
: snapshot1
: 3.0
Assigned To: Julie Pichon
Nir Magnezi
https://blueprints.launchpad.net/hori...
: TestOnly, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-13 14:22 EST by Perry Myers
Modified: 2015-02-15 17:02 EST (History)
5 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.1.1-1.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 11:03:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 18720 None None None Never

  None (edit)
Description Perry Myers 2013-01-13 14:22:30 EST
Add migrate/resize operation support to Horizon
Comment 1 Julie Pichon 2013-01-14 04:44:59 EST
Migrate tracked upstream at:

https://blueprints.launchpad.net/horizon/+spec/migrate-instance

Merged in grizzly as part of:

https://review.openstack.org/#/c/18720/


There hasn't been any work upstream toward surfacing the Resize option in Horizon yet, though the Migrate patch sets up a good foundation to do so.
Comment 2 Julie Pichon 2013-05-14 07:20:41 EDT
Wouldn't it make sense to break this down into 2 bugs?

- Migrate is available in Grizzly
- Resize hasn't been implemented upstream yet
Comment 3 Perry Myers 2013-05-14 09:14:58 EDT
Yes, let's track migrate testing on this bug (make it TestOnly) and create new bug for Resize
Comment 4 Julie Pichon 2013-05-14 09:50:55 EDT
Ok, filed bug 962818 for tracking resize support in Horizon.
Comment 5 Nir Magnezi 2013-05-26 03:48:49 EDT
Verified NVR: python-django-horizon-2013.1.1-1.el6ost.noarch

Taking previous comments into account, I verified the migration part only.
https://blueprints.launchpad.net/horizon/+spec/migrate-instance

1. Login as admin.
2. Launch an instance.
3. Go to Admin panel.
4. Go to instances and find the instance you want to migrate
5. Click More
6. See that the Migrate Instance is listed.
7. Click migrate
8. See that the Host column value was changed to a different host[1] (Shared storage etc..)

[1] Please note that live migration requires host configuration
    http://docs.openstack.org/trunk/openstack-compute/admin/content/live-migration-usage.html
    https://bugzilla.redhat.com/show_bug.cgi?id=894783
Comment 6 Julie Pichon 2013-05-27 04:20:48 EDT
Note that the current migration support is for "cold" migration only (as opposed to live migration). It may require "allow_resize_to_same_host" [0] in the Nova config to be set to true in a single-node environment. Thanks for verifying this!


[0] https://wiki.openstack.org/wiki/NovaConfigOptions#defined_in_nova.flags
Comment 8 errata-xmlrpc 2013-05-29 11:03:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0878.html

Note You need to log in before you can comment on or make changes to this bug.