Bug 894917 - RFE: Support database row archiving/deletion [NEEDINFO]
RFE: Support database row archiving/deletion
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
2.0 (Folsom)
All Linux
medium Severity medium
: Upstream M1
: 4.0
Assigned To: David Ripton
Brent Eagles
https://blueprints.launchpad.net/nova...
: FutureFeature, OtherQA
Depends On: 960644 1221962
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-01-13 20:41 EST by Perry Myers
Modified: 2015-05-15 06:46 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.8.b2.el6ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 18:57:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mlopes: needinfo? (dripton)


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Perry Myers 2013-01-13 20:41:21 EST
This tracks upstream blueprint: https://blueprints.launchpad.net/nova/+spec/db-archiving
Comment 1 David Ripton 2013-02-18 13:47:52 EST
The upstream development work is done for this blueprint; it will be in Grizzly final.
Comment 4 David Ripton 2013-03-05 11:22:27 EST
There's an upstream bug related to this: https://bugs.launchpad.net/nova/+bug/1137977  Foreign keys mess up archiving.  I need to fix this by Grizzly final.
Comment 5 David Ripton 2013-03-26 11:19:14 EDT
Fixed the upstream bug https://bugs.launchpad.net/nova/+bug/1137977 in upstream commit bb1977718d697565d

They found another RHEL-only test failure bug https://bugs.launchpad.net/nova/+bug/1158828  It appears to be a problem with SQLAlchemy not reliably supporting SQLite foreign key constraints with the old version of SQLite that comes with RHEL 6.4  My upstream fix for that was to just skip the offending unit test if SQLite < 3.7 was detected.  Upstream commit c07ec51dba9b1

The backport needs to also include those two commits.
Comment 6 David Ripton 2013-04-24 14:45:08 EDT
Setting to POST because these commits are already in upstream Grizzly and will naturally get into 3.0.
Comment 12 errata-xmlrpc 2013-12-19 18:57:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.