Bug 89568 - gnome-sound-recorder does not work, period. does not record, crashes when playing, etc.
gnome-sound-recorder does not work, period. does not record, crashes when pla...
Status: CLOSED DUPLICATE of bug 85818
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2003-04-24 09:45 EDT by Jeffrey Silverman
Modified: 2015-01-07 19:04 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:52:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeffrey Silverman 2003-04-24 09:45:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
This is a repeat of bugs 85818, 88952, 80507, and 81850.  I just wasn't able to
add comments to those for whatever reason, so I am creating a "me too" new bug.

Suffice it to say that gnome-sound-recorder does not work *at*all*.  And this is
true on both my machine at home and my machine at work.

I installed RH9 from the ISOs available at ftp.redhat.com.  I have not updated
the gnome-media RPMs to be any newer than the RHL9 ISO RPMs.

My soundcard:
> lspci
<snip! irrelevant hardware>
00:0d.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 07)

modules used:
<snip! irrelevant mods>
emu10k1                68136   0 (autoclean)
ac97_codec             13544   0 (autoclean) [emu10k1]

Sound *does* come out just fine! Xmms and gnome-cd work, system sounds work, etc.

Also, using "/usr/bin/record" at the command line worked well and produced
good-sounding WAV files.

According to the help documents (when you choose Help->Contents on the
gnome-sound-recorder app)  the gnome-sound-recorder should have some options
that Redhat's shipped version does not have: Edit->Preferences (not there),
Edit->Echo, etc.  The whole "Edit" menu is not there!

<soapbox>RedHat ships with a lot of items that do not work or are not explained
correctly in the Help docs.  They really shouldn't do that.</soapbox>

Thanks for listening!
-Jeff S.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Applications->Sound&Video->Sound Recorder
2.Click "Record"
3.Click "Stop"
4.Click "Save" or "Save As"
4.Click "Play"

Actual Results:  Record - nothing appears to happen except the message changes
to "Recording..."
Save- 0 byte file is created
Play - on first playback, just a loud static noise for 1/10th second, then
nothing.  Nothing happens on subsequent playback.

Expected Results:  Record - feedback showing that a sound is beig recorded.
Save - this new WAV file is saved properly
Play - this new WAV file is played properly

Additional info:
Comment 1 Havoc Pennington 2003-04-24 12:10:55 EDT
We don't have any patches to the sound recorder or its docs, so all these issues
were present in the upstream gnome-media release.

I've forwarded many of them to bugzilla.gnome.org; if they aren't resolved 
by the next RHL release g-s-r will probably be removed as it looks 
bad to include broken stuff.

*** This bug has been marked as a duplicate of 85818 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:48 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.