Bug 85818 - gnome sound recorder creates 0 byte files in Phoebe 3/ RH 8.0.94
gnome sound recorder creates 0 byte files in Phoebe 3/ RH 8.0.94
Status: CLOSED DUPLICATE of bug 106104
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
: Triaged
: 89568 91636 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-03-08 01:22 EST by Elton Woo
Modified: 2015-01-07 19:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
email exchange to/from developer of application (4.09 KB, text/plain)
2003-03-08 01:23 EST, Elton Woo
no flags Details

  None (edit)
Description Elton Woo 2003-03-08 01:22:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
Recording a file with Gnome Sound Recorder, when user selects
"save" or "save as" a 0 byte file is created!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start Gnome Sound recorder with input from microphone or line-in
2. Increase speaker volume, so that input can be verified
Start recording and after "n" minutes, save the new recording
3. Select the saved file, and attempt to play it.    

Actual Results:  Gnome Sound recorder *consistently* creates a 0 byte file.

Expected Results:  A file should be created in a size appropriate to the length and 
quality of the recording.

Additional info:

This problem was observed in Phoebe 2 (RH 8.0.93), and still 
exists in Phoebe 3 (RH 8.0.94). The most current updates
from rawhide (to FEB. 22)have been applied to my system.

ALSA (from freshrpms) is installed:

gnome-alsamixer-0.9.2-fr1
alsaplayer-0.99.74-fr1
alsa-lib-0.9.0-fr0.rc7.1

using either of the following kernels
kernel-2.4.20-2.48 (Phoebe 3 default)
kernel-2.4.20-2.54 (most current from rawhide)


I have also contacted the author of Gnome Sound Recorder.
(Kindly refer to attachment).
Comment 1 Elton Woo 2003-03-08 01:23:33 EST
Created attachment 90529 [details]
email exchange to/from developer of application
Comment 2 adam allen 2003-03-08 13:52:44 EST
I can confirm this also occurs on my system- which is vanilla Phoebe3 without ALSA.
Comment 3 adam allen 2003-03-10 16:05:19 EST
Tried the steps described in  attachment 90529 [details] with the following output.
Soundcard is an AWE-64. The result is a 4K wav file, which fails to play, the
command returns to the command prompt a few a few seconds.


[root@blackswan root]# gst-launch osssrc ! wavenc ! filesink location=temp-test.wav
INFO ( 2322: 0) Initializing GStreamer Core Library version 0.6.0
INFO ( 2322: 0) CPU features: (0c040843) MMX
registry: loaded user_registry in 0.000337 seconds
          (/root/.gstreamer/registry.xml)
registry: loaded global_registry in 0.298376 seconds
          (/var/cache/gstreamer-0.6/registry.xml)
GStreamer-INFO: 0 live buffer(s)
GStreamer-INFO: 0 live bufferpool(s)
GStreamer-INFO: 0 live event(s)
RUNNING pipeline
ERROR: /pipeline0/osssrc0: error reading data (Input/output error)
execution ended after 3 iterations (sum 5513902000 ns, average 1837967333 ns,
min 510000 ns, max 4999501000 ns)
GStreamer-INFO: 0 live buffer(s)
GStreamer-INFO: 0 live bufferpool(s)
GStreamer-INFO: 0 live event(s)

Comment 4 Havoc Pennington 2003-04-24 12:10:59 EDT
*** Bug 89568 has been marked as a duplicate of this bug. ***
Comment 5 Havoc Pennington 2003-08-06 17:18:50 EDT
*** Bug 91636 has been marked as a duplicate of this bug. ***
Comment 6 Elton Woo 2003-11-02 16:58:15 EST
I have just tried, and though it no longer creates a 0 byte file, the
Gnome Sound Recorder (version 2.4.0) locks up when recording under KDE,
and abends when playback of a recorded file is attempted under Gnome
(Fedora Core 1).
versions: gnome-audio-1.4.0-6, gnome-media-2.4.0-2, gnome-utils-2.4.0-1
Comment 7 Ben Woodard 2004-01-25 19:15:48 EST
RHL 8 is no longer a supported product. This bug still exists in RHEL3
and so I'm closing this bug as a dup of the version of the bug for RHEL3.

*** This bug has been marked as a duplicate of 106104 ***
Comment 8 Red Hat Bugzilla 2006-02-21 13:52:08 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.