Bug 896411 - gnfs-root-squash: read successful from nfsnobody for files created by root
gnfs-root-squash: read successful from nfsnobody for files created by root
Status: CLOSED DUPLICATE of bug 896408
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 04:19 EST by vpshastry
Modified: 2014-08-11 19:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 00:57:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description vpshastry 2013-01-17 04:19:46 EST
Description of problem:


------------   
On server
------------
[root@localhost ~]# gluster volume info dist-rep
 
Volume Name: dist-rep
Type: Distributed-Replicate
Volume ID: 3a9fb84b-6f4b-4bd6-aa2b-6fe86fbc44be
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.70.37.148:/export/dr
Brick2: 10.70.37.149:/export/drr
Brick3: 10.70.37.164:/export/ddr
Brick4: 10.70.37.101:/export/ddrr
Options Reconfigured:
features.root-squashing: enable

------------- 
On client
-------------

"with root user" (specifically since root-squash is enabled, so it behaves like nfsnobody)
[root@dhcp159-239 dir]# ls -l
drwxr-xr-x. 3 root      root      46 Dec 12 19:14 dir-n1

[root@dhcp159-239 dir]# ls -l dir-n1/1
-rwxrwx---. 1 root root 16 Dec 13 19:28 dir-n1/1
[root@dhcp159-239 dir]# 



[root@dhcp159-239 dir]# cat dir-n1/1
Hello 1\
jilted
[root@dhcp159-239 dir]# 

[root@dhcp159-239 dir]# id
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023



"after adding a new user called as dev1 under a new group called as devel"

[dev1@dhcp159-239 dir]$ cat dir-n1/1
cat: dir-n1/1: Permission denied
[dev1@dhcp159-239 dir]$ 

[dev1@dhcp159-239 dir]$ id
uid=500(dev1) gid=501(dev1) groups=501(dev1),500(devel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
[dev1@dhcp159-239 dir]$ 



Other then this problem, found out some other issue as well, hence filed this bug-887145. 

Version-Release number of selected component (if applicable):
glusterfs-3.3.0.5rhs-37.el6rhs.0.goldman.x86_64

How reproducible:
always
Comment 1 Amar Tumballi 2013-01-18 00:57:01 EST
valid only if the bug 896408 is fixed, so, rather keeping this open, keeping it as duplicate of that bug.

*** This bug has been marked as a duplicate of bug 896408 ***

Note You need to log in before you can comment on or make changes to this bug.