Bug 89643 - mount doesn't exit when mounting a drive share (like c$) does not
Summary: mount doesn't exit when mounting a drive share (like c$) does not
Status: CLOSED DUPLICATE of bug 90036
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-04-25 13:55 UTC by Justin Georgeson
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Georgeson 2003-04-25 13:55:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The following shell command does not return

mount -t smbfs -o username=jgeorgeson,uid=500,gid=100 //dragon/c$ \
  /mnt/dragon-c

I must hit <ctrl>+c to get back to the shell prompt. It is interesting to note,
however, that the actual mount succeeded, and was not affeced by the <ctrl>+c
signal. I have version 2.2.7a-8.9.0 of the samba packages.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. mount a default drive share (c$)
    

Actual Results:  it doesn't exit/return, I must hit <ctrl>+c to get back to the
shell

Expected Results:  The command should exit/return indicating the result of the
mount command

Additional info:

Comment 1 Tomas Mraz 2003-04-28 14:10:27 UTC
These bugs are dupes:
bug 82820, bug 88841, bug 89197


Comment 2 Jay Fenlason 2003-05-01 15:14:58 UTC
We've traced this down to a bug in glibc.  At the request of one of the glibc
maintainers, I've opened a new bug against glibc for it.  I'm going to mark all
these smbmount bugs as duplicates of the new bug.

*** This bug has been marked as a duplicate of 90036 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:48 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.