Bug 896670 - 'systemctl enable' does not resolve aliases
'systemctl enable' does not resolve aliases
Status: CLOSED DUPLICATE of bug 955379
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 12:34 EST by Nicholas Nachefski
Modified: 2013-05-06 13:20 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-06 13:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicholas Nachefski 2013-01-17 12:34:31 EST
systemctl resolves the 'nfs' alias to 'nfs-server' when performing a status. (expected behavior)

# systemctl status nfs
nfs-server.service - NFS Server
	  Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; disabled)
	  Active: active (exited) since Thu, 2013-01-17 11:06:29 CST; 17min ago
	Main PID: 970 (code=exited, status=0/SUCCESS)
	  CGroup: name=systemd:/system/nfs-server.service

However, it does not resolve this alias when attempting to 'enable' the same service alias.

# systemctl enable nfs
Failed to issue method call: No such file or directory

Instead, you have to reference the proper service name like so

# systemctl enable nfs-server
ln -s '/usr/lib/systemd/system/nfs-server.service' '/etc/systemd/system/multi-user.target.wants/nfs-server.service'


In the future, this will likely cause confusion for customers upgrading to RHEL7 (ie systemd noobs).
Comment 1 Lennart Poettering 2013-02-14 14:05:45 EST
*** Bug 911130 has been marked as a duplicate of this bug. ***
Comment 2 Lennart Poettering 2013-05-06 13:20:45 EDT

*** This bug has been marked as a duplicate of bug 955379 ***

Note You need to log in before you can comment on or make changes to this bug.