Bug 911130 - [RFE]: all systemctl commands including is-enabled should asume default .service type
[RFE]: all systemctl commands including is-enabled should asume default .serv...
Status: CLOSED DUPLICATE of bug 880353
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
17
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-14 07:54 EST by Miroslav Hradílek
Modified: 2013-03-07 10:50 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-07 10:50:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Miroslav Hradílek 2013-02-14 07:54:31 EST
Description of problem:
While it is said in manual that .service is the default unit type assumed when no suffix is specified it does not always work. For example 'is-enabled' command fails while 'start', 'stop', 'status' and 'show' work.

Version-Release number of selected component (if applicable):
systemd-44-23.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1."systemctl is-enabled abrtd"
  
Actual results:
Failed to issue method call: Invalid argument

Expected results:
enabled
Comment 1 Lennart Poettering 2013-02-14 14:05:45 EST

*** This bug has been marked as a duplicate of bug 896670 ***
Comment 2 Lennart Poettering 2013-03-07 10:50:26 EST

*** This bug has been marked as a duplicate of bug 880353 ***

Note You need to log in before you can comment on or make changes to this bug.