Bug 89693 - a wish fo AS-3 : dm (lvm2) plus evms
a wish fo AS-3 : dm (lvm2) plus evms
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
Brian Brock
http://evms.sourceforge.net/install-2...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 20:01 EDT by acount closed by user
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-26 10:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2003-04-25 20:01:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913

Description of problem:
I would like to see lvm2 and evms 2.0 into Advance Server 3.0
_at least_ in the first beta

http://people.sistina.com/~thornber/patches/
http://evms.sourceforge.net/

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.-
2.-
3.-
    

Additional info:
Comment 1 Rik van Riel 2003-04-26 10:08:03 EDT
Sorry, but for all intents and purposes the EVMS kernel code is dead, IBM
stopped developing it so IMHO it doesn't make sense for Red Hat to try and
support it.

Device mapper would have been promising, except for the fact that the last dm
patch for 2.4 at the URL you sent me to is from 2002-11-29 and that version has
known bugs,too. This patch looks as abandoned as EVMS, at least for 2.4.

I don't think it would be responsible for Red Hat to ship code in an enterprise
product when that code has been abandoned by its authors.  As much as I myself
prefer DM over LVM1, it just wouldn't be responsible.

Sorry.
Comment 2 acount closed by user 2003-04-26 11:00:31 EDT
rik, you go too fast :-). EVMS _1.2.xx_ is dead because alan and company don't
like spaghetti kernel code,ok. This tree is frozen and only bugs fixes are made.
United Linux and SuSE use it in their enterprise version.
I am not telling to user this one.

But EVMS >2.0.0 is _only_ a _user space tool_ based upon user-space volume
discovery and communication with existing kernel drivers such as
MD/Software-RAID and Device-Mapper. Not kernel code!!
And it is stable and well maintained. Latest version is dated March 29, 2003

which did dm url you browse through?
because I can see very recent dm code there:

http://people.sistina.com/~thornber/patches/2.4-stable/2.4.20/?M=D

[   ] 2.4.20-dm-10.tar.bz2    27-Mar-2003 04:18    46k 

and at official site has recent code too:

ftp://ftp.sistina.com/pub/LVM2/device-mapper/

-r--r--r--   1 agk      ftp        275964 Mar 27 16:55 device-mapper.0.96.08.tgz

Alan(cox) ships a very old version(1.0.3 2002-08-5) into .21-rc1-ac2 when the
stable version is  1.0.10 2003-03-26 

storage is a _real problem_ for a lot of companies that must to use Veritas
VxVM+Sun_OS Solaris. It is very expensive license and the integration with
Sun_OS Solaris is not easier. And a migration it is a nightmare.

I think it this is one big _real_ fault to adopt linux in medium storage
servers. All the people that use servers aren't hackers and they want a GUI to
control the storage.

Do you have more  doubts?
Comment 3 acount closed by user 2003-04-26 11:04:16 EDT
It forgot to me:

-thank you for your time-
Comment 4 Rik van Riel 2003-04-26 14:40:03 EDT
You're making good arguments, I'll pass on your ideas to management. Note
however that I cannot make any promises at this stage...
Comment 5 acount closed by user 2003-04-26 15:45:20 EDT
I _only_ wish if lvm2+evs2 are _stable_ at rh stress test. They should be  put 
into the _first beta_.

Because next chance is too far = 1.5 year late with AS-4 and sure with a 2.6
kernel. Or a valid option is make it sooner into a  AS-3 Quarterly Update

-thanks-
Comment 6 Christoph Hellwig 2003-05-02 04:14:40 EDT
The kernel-2.4.20*.ent kernels for the RH AS prerelease (alpha, beta, I dunno)
contain a (slightly outdated) DM driver.
Comment 7 acount closed by user 2003-07-18 19:07:35 EDT
more news at lvm front:

LVM 2.0/Device-Mapper 1.0 available at ftp.sistina.com for kernels 2.4.20 and
2.4.21, more information:

http://marc.theaimsgroup.com/?l=linux-kernel&m=105854670425970&w=2

Note You need to log in before you can comment on or make changes to this bug.