Bug 89696 - eggcups constantly looks up localhost
eggcups constantly looks up localhost
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: desktop-printing (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 98657 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-25 20:52 EDT by Ulrich Drepper
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-28 03:57:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2003-04-25 20:52:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030420

Description of problem:
eggcups constantly calls gethostbyname("localhost") (or a function which results
in the same kind of lookup).  This is on a machine which uses a remote printer.
 The lookup happens about once ever 3-4 secs.  This really shouldn't be
necessary.  The IP address won't change.


Version-Release number of selected component (if applicable):
desktop-printing-0.1.10-6

How reproducible:
Always

Steps to Reproduce:
1.Start machine with Gnome desktop
2.add eggcups to panel
3.
    

Actual Results:  one host lookup every couple of seconds

Expected Results:  One lookup at startup time

Additional info:

You can observe the lookup by running nscd in debug mode

/usr/sbin/nscd -d

make sure nscd isn't running already.
Comment 1 Tim Waugh 2003-04-28 03:57:03 EDT
This particular bug was fixed in 0.1.10-7; the more general issue of needing to
poll at all is fixed properly in rawhide (requires dbus, new cups).
Comment 2 Tim Waugh 2003-07-07 04:03:56 EDT
*** Bug 98657 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.