Bug 98657 - CUPS writes to log file every five seconds
CUPS writes to log file every five seconds
Status: CLOSED DUPLICATE of bug 89696
Product: Red Hat Linux
Classification: Retired
Component: desktop-printing (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-06 18:04 EDT by Matthew Saltzman
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2003-07-06 18:04:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030630

Description of problem:
The CUPS daemon writes an entry to /var/log/cups/access_log every five seconds
with the following form:

localhost - - [06/Jul/2003:17:49:25 -0400] "POST / HTTP/1.1" 200 219

This makes for huge log files with little useful information:

$ cd /var/log/cups

$ ls -l access_log*
-rw-r--r--    1 lp       sys        684273 Jul  6 17:50 access_log
-rw-r--r--    1 lp       sys       5327172 Jul  6 04:02 access_log.1
-rw-r--r--    1 lp       sys       4205427 Jun 29 23:25 access_log.2
-rw-r--r--    1 lp       sys       6477304 Jun 22 04:02 access_log.3
-rw-r--r--    1 lp       sys       7677744 Jun 15 04:02 access_log.4

$ wc access_log*
   9949   99490  686481 access_log
  77205  772050 5327172 access_log.1
  60947  609470 4205427 access_log.2
  93873  938730 6477304 access_log.3
 111269 1112690 7677744 access_log.4
 353243 3532430 24374128 total

$ LANG=C grep -v "200 219" access_log* | wc
   1270   12700  104501

It also means that laptops running CUPS can never spin down their hard drives.

Version-Release number of selected component (if applicable):
cups-1.1.17-13.3

How reproducible:
Always

Steps to Reproduce:
1. Install, configure, and run CUPS
2. tail -f /var/log/cups/access_log
3.
    

Actual Results:  Log lines (identical except for time stamp) appear every five
seconds.

Expected Results:  Log lines should appear when something interesting happens.

Additional info:
Comment 1 Tim Waugh 2003-07-07 04:03:49 EDT

*** This bug has been marked as a duplicate of 89696 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:57 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.