Bug 89702 - Keys keep pressed while released
Keys keep pressed while released
Status: CLOSED DUPLICATE of bug 74635
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-26 04:44 EDT by Julien Olivier
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
It's my XF86Config file (3.12 KB, text/plain)
2003-04-29 12:46 EDT, Julien Olivier
no flags Details
It's my XFree86 logfile (37.72 KB, text/plain)
2003-04-29 12:47 EDT, Julien Olivier
no flags Details
It's /var/log/messages (125.73 KB, text/plain)
2003-04-29 12:50 EDT, Julien Olivier
no flags Details
A tgz archive containing two older /var/log/messages (87.85 KB, application/octet-stream)
2003-04-29 12:51 EDT, Julien Olivier
no flags Details
My lates /var/log/messages file targzipped (14.68 KB, application/octet-stream)
2003-04-29 13:35 EDT, Julien Olivier
no flags Details

  None (edit)
Description Julien Olivier 2003-04-26 04:44:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.2.1) Gecko/20030225

Description of problem:
Sometimes (about once an hour), a key I just pressed keeps pressed after I have
released it. For example, it happens that I am typing a text and, for no logical
reason, a character repeats itself while I don't have my hands on the keyboard,
giving something like thaaaaaaaaaaaaaaaat. If I press this key again, it stops
repeating itself. It can be a big problem when the key which keeps pressed is an
inviible key (like CTRL) because I don't notice it (as it doesn't _write_
anything) but pressing a key (for example 'c') will act like CTRL+'c' instead of
just 'c'. Here again, I have to type 'CTRL' again to go back to the normal
behaviour.

I gave it 'high' severity because you can lose data by typing the wrong key (for
example CTRL-'c' instead of 'c') or keeping the 'SUPPR' key pressed forever
while wanting to suppress only once.

Version-Release number of selected component (if applicable):
4.3

How reproducible:
Sometimes

Steps to Reproduce:
1.Type a text
2.Sometimes, a key repeats itself while not pressed anymore
3.Click on this key again
4.It's back to normal
    

Actual Results:  Here is an exampleeeeeeeeeeeeeeeee(...I put my hands on my
head...)eeeeeeeeeeeeeeeeeeeeeeeeee(...I press 'e'...)e of what I see sometimes.

Expected Results:  Here is an example of what I expect.

Additional info:

-I already had this bug on Redhat 8 (XFree 4.2)

-My hardware is a Fujitsu/Siemens Amilo-D laptop with an ATI Radeon Mobility M6.

-I have DRI enabled on Redhat 9 but I didn't have it on Redhat 8.

-I don't know if that bug exists in non-X mode as I only use X.
Comment 1 Mike A. Harris 2003-04-26 05:31:19 EDT
> -I don't know if that bug exists in non-X mode as I only use X.

Please find out, and provide that information here.  Also please attach
your X server log and config file, and your /var/log/messages as bugzilla
file attachments.
Comment 2 Mike A. Harris 2003-04-28 06:05:37 EDT
Please boot your machine into runlevel 3 and indicate if the problem occurs
at the console or not.

This type of problem is almost certainly a hardware related flaw, kernel bug
or somesuch, and unless I can reproduce it, then I can't debug it at the
software level.  I've never seen this behaviour on any hardware I've got
access to, and nobody else has reported this problem either, so you're going
to have to narrow the problem down yourself as to wether it is the
kernel, your hardware, X or something else, and then provide those details.

Please update ASAP.
Comment 3 Julien Olivier 2003-04-29 12:46:55 EDT
Created attachment 91389 [details]
It's my XF86Config file
Comment 4 Julien Olivier 2003-04-29 12:47:56 EDT
Created attachment 91390 [details]
It's my XFree86 logfile
Comment 5 Julien Olivier 2003-04-29 12:50:23 EDT
Created attachment 91391 [details]
It's /var/log/messages
Comment 6 Julien Olivier 2003-04-29 12:51:39 EDT
Created attachment 91392 [details]
A tgz archive containing two older /var/log/messages
Comment 7 Julien Olivier 2003-04-29 12:55:34 EDT
Sorry for being so long to anwser.

I attached the files you asked me for.

I also tried to reproduce my problem in runlevel 3 but I couldn't.

BUT that doesn't mean that can't happen in runlevel 3 because in fact it happens
so rarely that I should use my machine in runlevel 3 for 1 whole day to be
perfectly sure that never happens un rl3.

If I happen to reproduce it in runlevel 3, I'll tell you here, on bugzilla.

Thanks for your time !
Comment 8 Julien Olivier 2003-04-29 13:33:08 EDT
I finally happened to reproduce the bug in non-X mode.

Here's what happened. I was trying to type spanish characters (just for fun...)
so I tried to combine ALT-GR, CTRL, SHIFT, ALT, FN, the WINDOWS KEY etc... with
normal letters quite randomly and check what it wrote (I did it in X). After a
while, I noticed that when I typed normal letters (without any modifier
pressed), strange symbols appeared. I understood that one (or more) of the
modifiers I tried was probably blocked. SO, I switched to the first non-X
virtual screen (CTRL-ALT-F1). There, I tried to log in. typing my login worked
(julo) but trying to type numbers (SHIFT+1 on my keyboard) didn't work. So, I
tried to press each of the modifiers one time so stop the strange behaviour. And
that worked. I could type numbers again. Then, I went back to X and it worked too.

I'll attach my /var/log/messages file.
Comment 9 Julien Olivier 2003-04-29 13:35:34 EDT
Created attachment 91393 [details]
My lates /var/log/messages file targzipped
Comment 10 Mike A. Harris 2003-04-29 15:58:32 EDT
As suspected, this problem occurs outside of XFree86, so it can't be an
XFree86 related problem.  It is either a hardware issue, or a kernel issue.
I rather suspect the former, however I'll reassign it to the kernel
component for comment.
Comment 11 Julien Olivier 2003-10-27 17:49:00 EST

*** This bug has been marked as a duplicate of 74635 ***
Comment 12 Red Hat Bugzilla 2006-02-21 13:52:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.