Bug 89863 - No SCSI RAID detected
No SCSI RAID detected
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-28 21:31 EDT by Alex F. Evonosky
Modified: 2007-04-18 12:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 23:12:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex F. Evonosky 2003-04-28 21:31:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Description of problem:
I am currently using RH7.3 as a production server.  Runs very well!  I wanted 
to
upgrade this server top RH9.  Upon installation, It will not see any of the 
hard
drives.  It loads the AIC7xxxx and megaraid, but after that, is states it 
cannot
see any hard drives.  

Here is from lspci:

[alexevon@linux2 alexevon]$ lspci
00:00.0 Host bridge: Intel Corp. 440GX - 82443GX Host bridge
00:01.0 PCI bridge: Intel Corp. 440GX - 82443GX AGP bridge
00:02.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:08.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 05)
00:0c.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X (rev 
5c)
02:04.0 SCSI storage controller: Adaptec AHA-2940U2/U2W / 7890/7891
02:06.0 SCSI storage controller: Adaptec AIC-7860 (rev 03)
02:0a.0 PCI bridge: Intel Corp. 80960RP [i960 RP Microprocessor/Bridge] (rev 
03)
02:0a.1 I2O: Intel Corp. 80960RP [i960RP Microprocessor] (rev 03)


This works great on 7.3.   Is there any "extras" I need to apply?  I tried
"linux nomodprobe", linux apic, and shows the same thing.  Any help would
greatly be 
appreciated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH9 with a AIC 7xxxx and megaraid module
2.
3.
    

Additional info:
Comment 1 Michael Fulbright 2003-04-29 12:07:26 EDT
Mike do you have this hardware to verify this report with?
Comment 2 Alex F. Evonosky 2003-05-06 11:27:06 EDT
Here are the Bios information... this is from RedHAt 7.3

[root@linux2 alexevon]# dmesg
Linux version 2.4.18-3smp (bhcompile@daffy.perf.redhat.com) (gcc version 2.96
20000731 (Red Hat Linux 7.3 2.96-110)) #1 SMP Thu Apr 18 07:27:31 EDT 2002
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 00000000000a0000 (usable)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001fffe000 (usable)
 BIOS-e820: 000000001fffe000 - 0000000020000000 (reserved)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
 BIOS-e820: 00000000fff80000 - 0000000100000000 (reserved)
found SMP MP-table at 000fe710
hm, page 000fe000 reserved twice.
hm, page 000ff000 reserved twice.
hm, page 000f0000 reserved twice.
On node 0 totalpages: 131070
zone(0): 4096 pages.
zone(1): 126974 pages.
zone(2): 0 pages.
Intel MultiProcessor Specification v1.4
    Virtual Wire compatibility mode.
OEM ID: DELL     Product ID: PowerEdge 7C APIC at: 0xFEE00000
Processor #1 Pentium(tm) Pro APIC version 17
Processor #0 Pentium(tm) Pro APIC version 17
I/O APIC #2 Version 17 at 0xFEC00000.
Processors: 2
Kernel command line: ro root=/dev/sda2
Comment 3 Thomas Smith 2003-09-04 21:01:15 EDT
I have the exact same problem but without the SCSI twist and I'm running RH7.2.
I have 4 IDE drives and three RAID partition (md0, md1, md2)--one RAID0, one
RAID1, and one RAID5.

I start the upgrade by booting from a floppy. I choose "linux text". It loads
and tells me it can't detect any valid installations. The RAID drivers appear to
load but the devices don't mount.

I tried the suggestion in Bug 65192 but got many anaconda errors and the
installation halted.

I haven't many problems with Redhat's installation routine so I'm not real
familiar with troubleshooting it. Please let me know if there's any information
I can provide about the install, log files, or whatnot so I can do so.
Comment 4 Jeremy Katz 2003-10-21 21:36:48 EDT
Can you copy /tmp/syslog and /tmp/anaconda.log from the installer environment to
a floppy and attach them to this bug report?
Comment 5 Jeremy Katz 2004-10-04 23:12:43 EDT
Closing due to inactivity.  Please reopen if you have further
information to add from a newer release.

Note You need to log in before you can comment on or make changes to this bug.