Bug 89953 - rpm -V reports "prelinked was modified"
rpm -V reports "prelinked was modified"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-04-30 06:04 EDT by Michael Young
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.3.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-12 07:41:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2003-04-30 06:04:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
On a prelinked system I am getting a lot of errors when running rpm -V such as
(from rpm -V mozilla)
prelink: /usr/lib/libgkgfx.so: prelinked file was modified
S.?.....   /usr/lib/libgkgfx.so
I have not modified the files, though maybe this is a result of running prelink
-a, updating a few packages (possibly including glibc) then running prelink -a
again. prelinking such files again doesn't fix the problem nor does running
prelink -a, but unprelinking and reprelinking does. What should happen is
prelink -a should produce a fully prelinked system, without any errors like
this, also rpm should still be able to attempt to check the file against it's
database even if there are prelink errors, as the prelink errors may not be
related to the integrity of the file being checked.
Comment 1 Jakub Jelinek 2003-07-08 19:09:17 EDT
Please try prelink from rawhide.
Comment 2 Michael Young 2003-07-09 04:38:57 EDT
I tried prelink -a from 0.2.1-2 on top of what I already had and am getting lots
of "prelinked file size differs" errors. I will try unprelinking everything, and
see if I can reproduce the error.
Comment 3 Jakub Jelinek 2003-07-09 04:44:49 EDT
That's expected. I had to change the prelinking layouting (and added some C++
optimizations), so that reprelinking a file results in bitwise same file
as would going from unprelinked file directly.
But prelink -ua should cure this and from now on, unless an incompatible change
is done in prelink again, should verify files properly even after multiple prelinking
(well, sans possible bugs as usual, but prelink make check already tests this
and I did some further testing).
Comment 4 Michael Young 2003-07-24 07:21:05 EDT
The "prelinked file was modified" error is back. I have upgraded to severn and
prelinked a couple of times, plus played with glibc a bit.
Comment 5 Michael Young 2003-08-08 05:50:31 EDT
I have now unprelinked and reprelinked everything with 0.3.0-1, then upgraded to
0.3.0-2, and again have 3 "prelinked file was modified" errors reported by rpm
-vVa. I have tried reprelinking the individual files (with and without the -q
option), and also prelink -qavvv but the error is still there.
Comment 6 Jakub Jelinek 2003-08-08 05:53:27 EDT
Ok, can I have one of those binaries (the one with fewest dependencies)
and all libraries it depends on?
tar cjhf /tmp/libs.tar.bz2 the_program `ldd the_program|awk '{print $3}'`
Thanks.
Comment 7 Michael Young 2003-08-11 11:29:15 EDT
With prelink-0.3.0-3 I am getting prelinked file was modified warning from most,
if not all libraries. I have tried prelink -qa and prelink -a so far, and will
try unprelinking and reprelinking everything, to see if the problem is due to
inconsistencies from the earlier 0.3.0 packages.
Comment 8 Michael Young 2003-08-12 05:48:54 EDT
reprelinking everything has cleared all prelink warnings from rpm. I will close
this bug, and reopen it if the problem reoccurs.
Comment 9 Michael Young 2003-11-10 11:46:15 EST
My system has managed to reproduce the problem again,
prelink=0.3.0-13, eg. with /sbin/fsck, but lots of other libraries as
well.
Comment 10 Michael Young 2004-01-12 07:41:53 EST
I reprelinked again. If this reoccurs I will open a fresh bug.

Note You need to log in before you can comment on or make changes to this bug.