Bug 900 - lsof broken with new Kernel (2.0.36) ?
lsof broken with new Kernel (2.0.36) ?
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: lsof (Show other bugs)
5.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
: 1180 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-20 15:39 EST by paolo.saggese
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-09 00:14:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paolo.saggese 1999-01-20 15:39:52 EST
Program "lsof" does not work on my RH 5.2 boxes:

[root@pcsaggese /tmp]# lsof
lsof: WARNING: compiled for Linux release 2.0.34; this is
2.0.36.
lsof: kernel symbol address mismatch: get_options
      get_kernel_syms() value is 0x108d30; /boot/System.map
value is 0x108cf8.
      There were 335 additional mismatches.
      /boot/System.map and the booted kernel may not be a
matched set.
[root@pcsaggese /tmp]#

I have upgraded to kernel 2.0.36 using the official RedHat
updates rpms.
Comment 1 Jeff Johnson 1999-01-20 16:34:59 EST
For now, try rebuilding from the lsof src.rpm, as in
	rpm --rebuild lsof-4.37-1.src.rpm
You might also try the 4.39 src rpm in Raw Hide.

Packaging for lsof that will work with any 2.0.x kernel cannot
be done. It may be possible with a 2.2.0 kernel ...
Comment 2 paolo.saggese 1999-01-21 15:01:59 EST
I had already tried rebuilding lsof from the .src.rpm [both the one
for RHL5.2 and the one from "RawHide"]. Unfortunately, none worked.

...will wait 2.2.0
Comment 3 Jeff Johnson 1999-02-16 12:45:59 EST
*** Bug 1180 has been marked as a duplicate of this bug. ***

lsof needs to be recompiled for kernel 2.0.36

------- Additional Comments From notting@redhat.com  02/15/99 17:13 -------


*** Bug 1181 has been marked as a duplicate of this bug. ***

lsof needs to be recompiled for kernel 2.0.36
Comment 4 Jeff Johnson 1999-03-09 00:14:59 EST
Fixed in lsof-4.40 security errata.

Note You need to log in before you can comment on or make changes to this bug.