Bug 90090 - Installer fails if you are doing hd install from partition which is also being mounted w/o formatting in ks
Summary: Installer fails if you are doing hd install from partition which is also bein...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 98921 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-02 11:15 UTC by Michael Jørgensen
Modified: 2007-04-18 16:53 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 03:12:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Jørgensen 2003-05-02 11:15:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I get a Traceback in anaconda during harddisk install, just after the partitions
have been formatted, but before the packages are being installed.

Apparently, a mount operation fails because the corresponding partition is
already mounted.





Version-Release number of selected component (if applicable):
/usr/src/build/229094-i386/install/usr/lib/anaconda

How reproducible:
Always

Steps to Reproduce:
1. Place iso files and kickstart file on a spare partion (e.g. hdb5).

2. In the kickstart file select the harddisk as installation media, (e.g.
harddrive --partition=hdb5 --dir=/RedHat90)

3. In the kickstart file select the spare partion as follows:
part /mnt/Install  --size 1  --onpart hdb5  --noformat

4. Perform a kickstart harddisk installation after booting from the installation
CD (e.g. linux: ks=hd:hdb5:/RedHat90/ks.cfg)


Actual Results:  The installation stops with the following Traceback (Sorry:
This is a *manual* copy-n-paste!)

/usr/bin/anaconda  line 739
text.py            line 459
dispatch.py        line 157
dispatch.py        line 225
packages.py        line 583
harddrive.py       line 225
harddrive.py       line 143
harddrive.py       line 181
/usr/lib/anaconda/isys.py  line 164
System Error: (16, 'Device or resource busy')



Expected Results:  A successfull install, including a successfull mount of the
partition hdb5.

Additional info:

Workaround:

If I comment out the line in kickstart file:
#part /mnt/Install  --size 1  --onpart hdb5  --noformat

then the install is successfull, but the partition is missing from the
/etc/fstab file. This can be added in the %post section of the kickstart file,
so this is a successfull workaround.

However, anaconda should not die like that.

Comment 1 Michael Fulbright 2003-05-05 15:59:36 UTC
I can see the source of this problem and its related to several problems with
doing hd based upgrades as well.  As time allows I am going to try to address it.

Comment 2 Michael Fulbright 2003-07-11 15:38:27 UTC
*** Bug 98921 has been marked as a duplicate of this bug. ***

Comment 3 Jeremy Katz 2004-10-05 03:12:57 UTC
I think that this should be better now.


Note You need to log in before you can comment on or make changes to this bug.