Bug 90103 - RFE: redhat-config-network Text user interfacee
Summary: RFE: redhat-config-network Text user interfacee
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 90447 (view as bug list)
Depends On:
Blocks: 87718
TreeView+ depends on / blocked
 
Reported: 2003-05-02 15:00 UTC by James Martin
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 1.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-13 00:22:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Martin 2003-05-02 15:00:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The spec file for redhat-config-network-1.0.4-0.AS21.1 now requires gnome-core
for some of the .so files it builds. This is also why it has changed from a
noarch package to a i386 package.  It now adds the following depedencies to
redhat-config-network (which didn't exist before).

gnome-core				
control-center			       
gdk-pixbuf-gnome		       
libgnomeprint15 		  
sawfish 			       
GConf				       
aumix				       
gnome-print			      
gnome-vfs				
librep					
oaf				     
rep-gtk 			    
rep-gtk-gnome			       
xscreensaver

Please make something similar like redhat-config-printer-tui for network
interfaces--- redhat-config-network-tui would be nice.. Netconfig is not
adequate-- it does not retreive previous settings and is not a very good
interface.  It seems extreme to require those 14 packages to configure my
network interface with a decent tool.

Version-Release number of selected component (if applicable):
redhat-config-network-1.0.4-0.AS21.1

How reproducible:
Always

Steps to Reproduce:
Try up2dating redhat-config-network without have Gnome installed.
    

Additional info:

I have an service request number with the Web Support team which you can view to
get additional information : 233713

Comment 1 Harald Hoyer 2003-05-06 13:36:24 UTC
this dependency was removed in 9
there is now:
redhat-config-network and redhat-config-network-tui


Comment 2 James Martin 2003-05-06 14:25:08 UTC
Oh that's, great, I guess I should upgrade my Red Hat AS installations to Red
Hat 9 then, eh?  This was a RFE for Enterprise Linux, not the free distro, thanks.

Comment 3 Harald Hoyer 2003-05-06 14:26:38 UTC
well, the next version of the Enterprise Linux will of course have that, too :)

Comment 4 Harald Hoyer 2003-05-08 15:23:05 UTC
*** Bug 90447 has been marked as a duplicate of this bug. ***

Comment 5 James Martin 2003-05-08 16:08:26 UTC
How about instead of us forcing to upgrade to another OS that you guys actually
fix the issue at hand?  What's next, the kernel is going to require KDE?  The
package did not require Gnome before, it should not require it now, as well as
those other libraries.  What we have now is a mistake by your Errata developers.

Comment 6 Harald Hoyer 2003-05-08 16:16:41 UTC
that's right.. the dependency was forgotten in the first place... but slipped in
as this was corrected.

Comment 7 Carlos R. Martinez 2003-05-08 20:41:05 UTC
So what is RedHat's direction on this package? Do we not include it as part of 
our Quartely patch upgrade? Is the fixed package going to be rebuilt as the 
original or are we going to be forced to install additional packages to 
satisfy its dependencies?


Note You need to log in before you can comment on or make changes to this bug.