Bug 90127 - (SCSI 3WARE)Bad: Installer crashed!
(SCSI 3WARE)Bad: Installer crashed!
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 88993 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-02 18:36 EDT by Kenneth Keating
Modified: 2007-04-18 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenneth Keating 2003-05-02 18:36:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
During installation on a system with a 3Ware 6410 or 6800 IDE Raid card, a crash
occurs prior to formatting the file systems:

<4> 3w-xxxx:scsi 0:unit #0: Command (df36f400) timed out
Unable to handle kernel NULL pointer dereference at virtual address....
...
scsi_eh_0: ...

The ...'s represent a stak trace

Redhat 8 installs just fine, bu 9 has this crash.


Version-Release number of selected component (if applicable):
3w-xxxx driver / scsi_eh_0

How reproducible:
Always

Steps to Reproduce:
1.Install Redhat 9 on a system with a 3ware Escalade 6410 or 6800
2.When ready to format... kaboom!
3.
    

Actual Results:  <4> 3w-xxxx:scsi 0:unit #0: Command (df36f400) timed out
Unable to handle kernel NULL pointer dereference at virtual address....
...
scsi_eh_0: ...


Expected Results:  The installation should have proceeded with bad block checks
and formatting of partitions

Additional info:
Comment 1 Kenneth Keating 2003-05-14 19:16:52 EDT
Is there any progress with resolving this issue?  I'm willing to test this and
gather more info for you.

Please update me as to the status of your investigation.

Thanks,  Ken
Comment 2 Alan Cox 2003-06-05 12:29:18 EDT
*** Bug 88993 has been marked as a duplicate of this bug. ***
Comment 3 Kenneth Keating 2003-07-08 22:07:36 EDT
What is going on to resolve this issue?  I have not heard a status report on
this issue for some time.

Is this being worked on?  Or is my 3ware card now garbage as far as Linux goes...
Comment 4 Need Real Name 2003-08-12 00:02:27 EDT
I also have this problem too. What Red Hat needs to do is provide a drive disk 
that overrides the default 3ware driver shipped with RH 9. I spoke with 3Ware 
on this subject, and their response is that Red Hat shipped a bad driver with 
RH9. If that is the case, there should be either an anaconda boot disk errata 
to download, or a driver disk so we can start the installer with "linux dd". 

A lot of people use 3Ware cards, its not something that can be ignored and have 
happy customers.
Comment 5 deniz 2003-10-13 00:26:05 EDT
Also present in kernel-2.4.20-xxx for RH 7.3

I have come across this bug not only in RH 9 upgrade/install, but also in RH
7.3, trying to upgrade from kernel-2.4.18-27.7.x to kernel-2.4.20-xxxx (any of
the kernel-2.4.20 upgrades)

Version of 3w-xxxx.c driver that causes this problem is 1.02.00.032. This is the
version of the driver that is present in RH 9 kernels as well as in RH 7.3
kernel-2.4.20 upgrades. 

Last version of 3w-xxxx.c driver that I can confirm working is 1.02.00.025. This
is the version in RH 7.3 kernel-2.4.18-27.7.x . 

There is a comment in 3ware web site knowledge base. They don't seem to allow
deep linking but here is the Question ID: Q10364 . Essentially they say to use a
different driver. 

Comment 6 deniz 2003-10-13 03:29:47 EDT
RH 9 install workaround

Hello,

I haven't tried this on the machine with the 6800 card yet, but I have tried it
on a 7500 card machine and at least the install/modify procedure works. 

I took the 3w-xxxx.c and 3w-xxxx.h from kernel-2.4.18-27.7.x . I replaced the
files in kernel-2.4.20-8 with these and re-compiled the source, creating all the
different flavors of kernel binary RPMS. I also took the compiled 3w-xxxx.o from
kernel-BOOT that I compiled from modified source. 

I then took drvblock.img, opened it up, unpacked modules.cgz, replaced 3w-xxxx.o
with the new 3w-xxxx.o and re-packed everything. 

I created an FTP install tree for RH 9, and replaced the default kernel RPMs
with the ones that I compiled. 

I created floppies of bootdisk.img, drvnet.img with the stock images and
drvblock.img with the modified image file. 

I then did "dd" during install and used the drvblock.img diskette. 




Comment 7 Bugzilla owner 2004-09-30 11:40:52 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.