Bug 901360 - [abrt] yum-utils-1.1.31-6.fc18: yumRepo.py:963:_getFile:NoMoreMirrorsRepoError: failure: repodata/20555427e96e7c41f8082fd42c0025fbd4dedbfebde9fe006aa70299cbd1510a-comps-f18.xml from fedora: [Errno 256] No more mirrors to try.
[abrt] yum-utils-1.1.31-6.fc18: yumRepo.py:963:_getFile:NoMoreMirrorsRepoErro...
Status: CLOSED DUPLICATE of bug 880722
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
abrt_hash:e7e447d0983e4b3c0b94229a55e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-17 22:53 EST by Malar Kannan
Modified: 2013-02-08 10:39 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 09:09:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (15.80 KB, text/plain)
2013-01-17 22:53 EST, Malar Kannan
no flags Details
File: core_backtrace (470 bytes, text/plain)
2013-01-17 22:53 EST, Malar Kannan
no flags Details
File: environ (1.77 KB, text/plain)
2013-01-17 22:53 EST, Malar Kannan
no flags Details
File: smolt_data (3.69 KB, text/plain)
2013-01-17 22:54 EST, Malar Kannan
no flags Details

  None (edit)
Description Malar Kannan 2013-01-17 22:53:48 EST
Description of problem:
yum update; then crashed

Version-Release number of selected component:
yum-utils-1.1.31-6.fc18

Additional info:
cmdline:        /usr/bin/python -tt /usr/bin/reposync --arch=x86_64 -gnlm
dso_list:       yum-3.4.3-47.fc18.noarch
executable:     /usr/bin/reposync
kernel:         3.7.2-201.fc18.x86_64
uid:            0
Comment 1 Malar Kannan 2013-01-17 22:53:52 EST
Created attachment 681992 [details]
File: backtrace
Comment 2 Malar Kannan 2013-01-17 22:53:54 EST
Created attachment 681993 [details]
File: core_backtrace
Comment 3 Malar Kannan 2013-01-17 22:53:57 EST
Created attachment 681994 [details]
File: environ
Comment 4 Malar Kannan 2013-01-17 22:54:00 EST
Created attachment 681995 [details]
File: smolt_data
Comment 5 Zdeněk Pavlas 2013-01-18 09:09:33 EST
Again, a race.  _retrieveMD() didn't find a (complete) file on disk, but other process retrieved whole file before we stat() the local copy, and issue an invalid request for 0 remaining bytes.

*** This bug has been marked as a duplicate of bug 880722 ***

Note You need to log in before you can comment on or make changes to this bug.