Bug 880722 - [abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:1500:_commonRetrieveDataMD_list:OSError: [Errno 2] No such file or directory
[abrt] yum-utils-1.1.31-4.fc17: yumRepo.py:1500:_commonRetrieveDataMD_list:OS...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:6b8fcfd2912557a85fd0ed38fd0...
:
: 901360 901361 904287 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-27 11:35 EST by Andrey Budantsev
Modified: 2013-02-01 10:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-25 16:36:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (24 bytes, text/plain)
2012-11-27 11:35 EST, Andrey Budantsev
no flags Details
File: environ (2.96 KB, text/plain)
2012-11-27 11:35 EST, Andrey Budantsev
no flags Details
File: executable (17 bytes, text/plain)
2012-11-27 11:35 EST, Andrey Budantsev
no flags Details
File: smolt_data (3.79 KB, text/plain)
2012-11-27 11:35 EST, Andrey Budantsev
no flags Details
File: core_backtrace (699 bytes, text/plain)
2012-11-27 11:35 EST, Andrey Budantsev
no flags Details

  None (edit)
Description Andrey Budantsev 2012-11-27 11:35:01 EST
Version-Release number of selected component:
yum-utils-1.1.31-4.fc17

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python -tt /usr/bin/reposync -c Descriptors/blackfin.repo -a x86_64 --source -r blackfin-current -p mirrors/blackfin/current/x86_64/0/1/
kernel:         3.6.7-4.fc17.x86_64

backtrace:
:yumRepo.py:1500:_commonRetrieveDataMD_list:OSError: [Errno 2] No such file or directory
:
:Traceback (most recent call last):
:  File "/usr/bin/reposync", line 352, in <module>
:    main()
:  File "/usr/bin/reposync", line 169, in main
:    my.doRepoSetup()
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 670, in doRepoSetup
:    return self._getRepos(thisrepo, True)
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 722, in _getRepos
:    self._repos.doSetup(thisrepo)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 134, in doSetup
:    self.retrieveAllMD()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 92, in retrieveAllMD
:    downloading = repo._commonRetrieveDataMD_list(mdtypes)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1500, in _commonRetrieveDataMD_list
:    os.rename(local, local + '.old.tmp')
:OSError: [Errno 2] No such file or directory
:
:Local variables in innermost frame:
:old_repo_XML: <yum.repoMDObject.RepoMD instance at 0x247b7a0>
:downloading: []
:odata: <yum.repoMDObject.RepoData instance at 0x2480b48>
:omdtype: 'primary_db'
:mdtype: 'primary'
:all_mdtypes: ['filelists', 'updateinfo', 'other', 'group', 'primary']
:self: <yum.yumRepo.YumRepository object at 0x239ed10>
:mdtypes: ['primary']
:_mdtype_eq: <function _mdtype_eq at 0x246bb18>
:ndata: <yum.repoMDObject.RepoData instance at 0x2484248>
:local: '/var/tmp/yum-abudantsev-uoqSMC/rpmfusion-free-updates-local/80f6e1aebdd6c30e08470ab8b707be1e90f06b97089a08d9b436527234d9c0e4-primary.sqlite.bz2'
:reverts: []
:nmdtype: 'primary_db'
Comment 1 Andrey Budantsev 2012-11-27 11:35:05 EST
Created attachment 652905 [details]
File: dso_list
Comment 2 Andrey Budantsev 2012-11-27 11:35:07 EST
Created attachment 652906 [details]
File: environ
Comment 3 Andrey Budantsev 2012-11-27 11:35:09 EST
Created attachment 652907 [details]
File: executable
Comment 4 Andrey Budantsev 2012-11-27 11:35:11 EST
Created attachment 652908 [details]
File: smolt_data
Comment 5 Andrey Budantsev 2012-11-27 11:35:17 EST
Created attachment 652909 [details]
File: core_backtrace
Comment 6 Zdeněk Pavlas 2012-11-28 05:36:40 EST
Thanks for the report.  Any chance to reproduce this?

Before renaming the old metadata file Yum verifies the file checksum, so this seems impossible to happen without something intervening.
Comment 7 Andrey Budantsev 2012-12-05 07:56:20 EST
I invoked 'yum install' accidentally when repository mirror were updating.
Comment 8 Zdeněk Pavlas 2012-12-05 11:13:04 EST
Thanks!  I think this is indeed a bug: reposync does not lock the cachedir.  Fixed this upstream.
Comment 9 Fedora Update System 2013-01-17 06:20:53 EST
yum-utils-1.1.31-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-7.fc18
Comment 10 Zdeněk Pavlas 2013-01-18 08:19:32 EST
*** Bug 901361 has been marked as a duplicate of this bug. ***
Comment 11 Zdeněk Pavlas 2013-01-18 09:09:33 EST
*** Bug 901360 has been marked as a duplicate of this bug. ***
Comment 12 Fedora Update System 2013-01-19 22:25:22 EST
Package yum-utils-1.1.31-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.31-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1128/yum-utils-1.1.31-7.fc18
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-01-25 16:36:10 EST
yum-utils-1.1.31-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Zdeněk Pavlas 2013-02-01 10:15:40 EST
*** Bug 904287 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.