This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 901421 - vdsm: KVM version miss in RHEVM 3.1 (when the host is RHEVH 6.4-20130116.3)
vdsm: KVM version miss in RHEVM 3.1 (when the host is RHEVH 6.4-20130116.3)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.2.0
Assigned To: Yaniv Bronhaim
Jiri Belka
infra
: Regression
: 902249 (view as bug list)
Depends On:
Blocks: 907480
  Show dependency treegraph
 
Reported: 2013-01-18 02:19 EST by Guohua Ouyang
Modified: 2016-02-10 14:04 EST (History)
15 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-7.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 907480 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 4 Yaniv Kaul 2013-01-18 02:59:27 EST
I does not report qemu-kvm's version, only qemu-kvm-rhev. 
On my 6.3, although I have qemu-kvm-rhev installed, this works correctly:

packages2 = {'kernel': {'release': '279.9.1.el6.x86_64', 'buildtime': 1346393064.0, 'version': '2.6.32'}, 'spice-server': {'release': '10.el6', 'buildtime': '1337611492', 'version': '0.10.1'}, 'vdsm': {'release': '44.3.el6_3', 'buildtime': '1357134556', 'version': '4.9.6'}, 'qemu-kvm': {'release': '2.295.el6_3.10', 'buildtime': '1355335067', 'version': '0.12.1.2'}, 'libvirt': {'release': '21.el6_3.7', 'buildtime': '1354896845', 'version': '0.9.10'}, 'qemu-img': {'release': '2.295.el6_3.10', 'buildtime': '1355335067', 'version': '0.12.1.2'}}


[root@master-vds11 vdsm]# rpm -q qemu-kvm
package qemu-kvm is not installed
[root@master-vds11 vdsm]# rpm -q qemu-kvm-rhev
qemu-kvm-rhev-0.12.1.2-2.295.el6_3.10.x86_64

And engine of course only expects qemu-kvm as the KVM package:
backend/manager/modules/vdsbroker/src/main/java/org/ovirt/engine/core/vdsbroker/vdsbroker/VdsProperties.java:    public static final String qemuKvmPackageName = "qemu-kvm";

The difference in VDSM is in caps.py:
In 6.3:
      KEY_PACKAGES = {'qemu-kvm': 'qemu-kvm-rhev',
                        'qemu-img': 'qemu-img-rhev',
                        'vdsm': 'vdsm',
                        'spice-server': 'spice-server',
                        'libvirt': 'libvirt'}

In 6.4:
        KEY_PACKAGES = ['qemu-kvm-rhev', 'qemu-img-rhev',
                        'vdsm', 'spice-server', 'libvirt']


Not sure why is that.
Comment 5 Jiri Belka 2013-01-21 07:32:37 EST
*** Bug 902249 has been marked as a duplicate of this bug. ***
Comment 6 Jiri Belka 2013-01-21 07:35:00 EST
I don't see KVM version even in 3.2 (BZ 902249, closed as duplicate).
Comment 8 Jiri Belka 2013-03-22 09:09:32 EDT
OK, tested with vdsm-4.10.2-12.0.el6ev.x86_64 (sf11) on 3.1 env (si27.4) and 3.2 env (sf11).
Comment 9 Itamar Heim 2013-06-11 04:42:23 EDT
3.2 has been released
Comment 10 Itamar Heim 2013-06-11 04:42:28 EDT
3.2 has been released
Comment 11 Itamar Heim 2013-06-11 04:42:40 EDT
3.2 has been released
Comment 12 Itamar Heim 2013-06-11 04:49:37 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.