Bug 901504 - libsmi included non-free files.
libsmi included non-free files.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libsmi (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-01-18 05:40 EST by mejiko
Modified: 2013-02-24 03:57 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-14 12:20:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 498476 None None None Never

  None (edit)
Description mejiko 2013-01-18 05:40:55 EST
Hello.

libsmi included non-free files. See debian bug number "498476" datails.
I think that this package be affected by debian bug number "498476". 


Question: Is this non-free files is "content" or "firmware" ?

I think that this non-free files is not content or firmware, Its code.


Suggests:

1. Remove non-free files and rebuild.

2. Replace fedora free (Fedora acceptable licensed file) files. 

3. Fix License tag (If this file is "content" or "firmware").

4. Remove Fedora repos.


Thanks.


Reference:

https://fedoraproject.org/wiki/Packaging:Guidelines#Code_Vs_Content
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Binary_Firmware
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
http://libreplanet.org/wiki/List_of_software_that_does_not_respect_the_Free_System_Distribution_Guidelines#libsmi2-common
Comment 1 mejiko 2013-01-18 05:41:45 EST
Blocking FE-Legal, This is license problem.
Comment 2 Jan Safranek 2013-01-21 04:16:32 EST
If I understand it correctly:
* Fedora cannot ship any MIB files which are generated from IETF RFCs in rpm packages
* Fedora *can* ship verbatim copy of the RFCs in rpm packages and generate MIB files from them during installation

Please confirm, I am not a lawyer. If the above is true, I can imagine some solution in rpm %post scripts (it won't be a nice one though).
Comment 3 mejiko 2013-02-10 04:25:39 EST
(In reply to comment #2)
> If I understand it correctly:
> * Fedora cannot ship any MIB files which are generated from IETF RFCs in rpm
> packages
> * Fedora *can* ship verbatim copy of the RFCs in rpm packages and generate
> MIB files from them during installation

Its true.
Comment 4 mejiko 2013-02-10 04:32:40 EST
This bug affected net-snmp, See bug 901505.
Comment 5 Rex Dieter 2013-02-11 14:09:11 EST
The license phrase in question (I assume, since it wasn't mentioned here specifically yet) is:

   However, this document itself may not be modified in any way, such as by
   removing the copyright notice or references to the Internet Society or
   other Internet organizations, except as needed for the purpose of
   developing Internet standards in which case the procedures for
   copyrights defined in the Internet Standards process must be followed,
   or as required to translate it into languages other than English. 

and debian considers these documentation:
http://wiki.debian.org/NonFreeIETFDocuments


One could try to argue this stuff should be consider "content" rather than documentation,
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Content_Licenses

"... The one exception is that we permit content (but only content) which restricts modification as long as that is the only restriction.".
Comment 6 Tom "spot" Callaway 2013-02-14 12:20:47 EST
From http://trustee.ietf.org/docs/Copyright-FAQ-2010-6-22.pdf

Section 2.5:

Code Components included in IETF Documents can be used for any purpose
pursuant to an open source license.

Section 3.1:

Can I use code that is included in IETF Documents in my software?

Yes. Code Components (see Question 3.2) that are embedded or included in IETF
Documents published on or after November 10, 2008, can be used, copied, distributed and modified by anyone in any manner under the open source Simplified BSD License, as described in Questions 3.2 and 3.3.

Section 3.2:

What is meant by “Code Components”?

Under the TLP, “Code Components” are any components intended to be directly
processed by a computer. This means that all forms of software code are Code
Components. The IETF Trust maintains a list of common code components at http://trustee.ietf.org/license-info/. The items on this list are automatically treated as “Code Components” for purposes of the TLP, but this list is illustrative only. 

*****

The current Code Components list explicitly calls out MIB modules:

http://trustee.ietf.org/license-info/Code-Components-List-4-23-09.txt

"o Management Information Base (MIB) modules"

This is the license the IETF puts Code Components on:
http://www.opensource.org/licenses/bsd-license.php

It is BSD, Free and GPL-compatible. They are fine, as is, in Fedora, as long as they come with the corresponding BSD license.

That license text was missing, so I have added it to libsmi in rawhide (and F17/F18).

*****

It is worth noting that this licensing policy was not in place when Debian initially noticed this issue, which is why they came to a different conclusion at the time. Many thanks to the IETF for making this change.
Comment 7 Fedora Update System 2013-02-14 13:36:53 EST
libsmi-0.4.8-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libsmi-0.4.8-11.fc17
Comment 8 Fedora Update System 2013-02-14 13:37:14 EST
libsmi-0.4.8-11.fc18,net-snmp-5.7.2-5.fc18.1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libsmi-0.4.8-11.fc18,net-snmp-5.7.2-5.fc18.1
Comment 9 Fedora Update System 2013-02-24 03:56:48 EST
libsmi-0.4.8-11.fc18, net-snmp-5.7.2-5.fc18.1 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-02-24 03:57:25 EST
libsmi-0.4.8-11.fc17, net-snmp-5.7.1-5.fc17.1 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.