Bug 901505 - net-snmp included non-free files.
Summary: net-snmp included non-free files.
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: net-snmp   
(Show other bugs)
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Safranek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2013-01-18 10:44 UTC by mejiko
Modified: 2013-02-24 08:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-24 08:56:55 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 498475 None None None Never

Description mejiko 2013-01-18 10:44:22 UTC
Hello.

net-snmp-libs included non-free files. See debian bug number "498475" datails.
I think that this package be affected by debian bug number "498475". 


Question: Is this non-free files is "content" or "firmware" ?

I think that this non-free files is not content or firmware, Its code.


Suggests:

1. Remove non-free files and rebuild.

2. Replace fedora free (Fedora acceptable licensed file) files. 

3. Fix License tag (If this file is "content" or "firmware").

4. Remove Fedora repos.


Thanks.


Reference:

https://fedoraproject.org/wiki/Packaging:Guidelines#Code_Vs_Content
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Binary_Firmware
https://fedoraproject.org/wiki/Licensing:Main?rd=Licensing#Good_Licenses
http://libreplanet.org/wiki/List_of_software_that_does_not_respect_the_Free_System_Distribution_Guidelines#libsnmp-base

Comment 1 mejiko 2013-01-18 10:44:58 UTC
Blocking FE-Legal, This is license problem.

Comment 2 mejiko 2013-02-10 09:31:32 UTC
This bug affected libsmi, See #901504.

Comment 3 mejiko 2013-02-10 09:42:02 UTC
I found typo (Comment 2).

incorrent: #901504

corrent: bug 901504

Sorry.

Comment 4 Tom "spot" Callaway 2013-02-14 17:40:31 UTC
From http://trustee.ietf.org/docs/Copyright-FAQ-2010-6-22.pdf

Section 2.5:

Code Components included in IETF Documents can be used for any purpose
pursuant to an open source license.

Section 3.1:

Can I use code that is included in IETF Documents in my software?

Yes. Code Components (see Question 3.2) that are embedded or included in IETF
Documents published on or after November 10, 2008, can be used, copied, distributed and modified by anyone in any manner under the open source Simplified BSD License, as described in Questions 3.2 and 3.3.

Section 3.2:

What is meant by “Code Components”?

Under the TLP, “Code Components” are any components intended to be directly
processed by a computer. This means that all forms of software code are Code
Components. The IETF Trust maintains a list of common code components at http://trustee.ietf.org/license-info/. The items on this list are automatically treated as “Code Components” for purposes of the TLP, but this list is illustrative only. 

*****

The current Code Components list explicitly calls out MIB modules:

http://trustee.ietf.org/license-info/Code-Components-List-4-23-09.txt

"o Management Information Base (MIB) modules"

This is the license the IETF puts Code Components on:
http://www.opensource.org/licenses/bsd-license.php

It is BSD, Free and GPL-compatible. They are fine, as is, in Fedora, as long as they come with the corresponding BSD license.

That license text was missing, so I have added it to net-snmp in rawhide (and F17/F18).

*****

It is worth noting that this licensing policy was not in place when Debian initially noticed this issue, which is why they came to a different conclusion at the time. Many thanks to the IETF for making this change.

Comment 5 Fedora Update System 2013-02-14 18:37:01 UTC
libsmi-0.4.8-11.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libsmi-0.4.8-11.fc17

Comment 6 Fedora Update System 2013-02-14 18:37:22 UTC
libsmi-0.4.8-11.fc18,net-snmp-5.7.2-5.fc18.1 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libsmi-0.4.8-11.fc18,net-snmp-5.7.2-5.fc18.1

Comment 7 Fedora Update System 2013-02-16 00:53:56 UTC
Package libsmi-0.4.8-11.fc18, net-snmp-5.7.2-5.fc18.1:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libsmi-0.4.8-11.fc18 net-snmp-5.7.2-5.fc18.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-2512/libsmi-0.4.8-11.fc18,net-snmp-5.7.2-5.fc18.1
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2013-02-24 08:56:58 UTC
libsmi-0.4.8-11.fc18, net-snmp-5.7.2-5.fc18.1 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2013-02-24 08:57:32 UTC
libsmi-0.4.8-11.fc17, net-snmp-5.7.1-5.fc17.1 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.