Bug 90154 - mkfontdir is missing release-notes
mkfontdir is missing release-notes
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rhl-release-notes-x86 (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ed Bailey
Ed Bailey
:
: 97171 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-03 13:57 EDT by Stig Nielsen
Modified: 2007-04-18 12:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-04 13:58:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Nielsen 2003-05-03 13:57:23 EDT
Description of problem:
When following the release notes for adding fonts you are presented with the
following message:
chkfontpath: error opening /usr/share/fonts/local/fonts.dir, unwilling to add path


Version-Release number of selected component (if applicable):
Redhat 9.0

How reproducible:
always on new installations

Steps to Reproduce:
1. Create the /usr/share/fonts/local/  directory (if it doesn't already exist):

mkdir /usr/share/fonts/local/

If you had to create /usr/share/fonts/local/, you must then add it to the X font
server (xfs) path:
chkfontpath --add /usr/share/fonts/local/

    
Corrective action:
Modify the release notes:

1. Create the /usr/share/fonts/local/  directory (if it doesn't already exist):

mkdir /usr/share/fonts/local/

If you had to create /usr/share/fonts/local/, you must then first create
fonts.dir add the new directory to the X font server (xfs) path:

cd /usr/share/fonts/local 
mkfontdir

chkfontpath --add /usr/share/fonts/local/

2. Copy the new font file into /usr/share/fonts/local/

3. Update the font information by issuing the following command:

ttmkfdir -d /usr/share/fonts/local/ -o /usr/share/fonts/local/fonts.scale

4. Reload the xfs font server using the following command:

service xfs reload
Comment 1 Owen Taylor 2003-05-05 16:44:05 EDT
Probably the addition of mkfontdir is needed, but the ordering should be:

 mkdir 
 cp
 ttmkfdir
 mkfontdir
 chkfontpath

Since the fonts.scale is needed for fonts.dir. 

However, trying this out, I'm getting an empty fonts.scale, so some
more studying is needed to figure that out.
Comment 2 Ed Bailey 2003-06-04 13:58:44 EDT
Hmmmm, WORKSFORME (Owen's sequence, that is -- the release notes as written is
definitely wrong).  Thanks for bring this to our attention!

I'm going to close this as NEXTRELEASE; the updated instructions will appear in
the release notes for the next release of Red Hat Linux.
Comment 3 Ed Bailey 2003-06-11 09:50:43 EDT
*** Bug 97171 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.