This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 901744 - [abrt] fritzing-0.7.5b-2.fc18: QMetaObject::activate: Process /usr/bin/Fritzing was killed by signal 11 (SIGSEGV)
[abrt] fritzing-0.7.5b-2.fc18: QMetaObject::activate: Process /usr/bin/Fritzi...
Status: CLOSED DUPLICATE of bug 852568
Product: Fedora
Classification: Fedora
Component: fritzing (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ed Marshall
Fedora Extras Quality Assurance
abrt_hash:577014f25459637c1dba83cbe3e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-18 18:13 EST by Dan Pascu
Modified: 2013-01-18 18:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-18 18:52:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (571.98 KB, text/plain)
2013-01-18 18:13 EST, Dan Pascu
no flags Details
File: cgroup (128 bytes, text/plain)
2013-01-18 18:13 EST, Dan Pascu
no flags Details
File: core_backtrace (121.38 KB, text/plain)
2013-01-18 18:13 EST, Dan Pascu
no flags Details
File: dso_list (13.59 KB, text/plain)
2013-01-18 18:13 EST, Dan Pascu
no flags Details
File: environ (1.35 KB, text/plain)
2013-01-18 18:14 EST, Dan Pascu
no flags Details
File: limits (1.29 KB, text/plain)
2013-01-18 18:14 EST, Dan Pascu
no flags Details
File: maps (36.92 KB, text/plain)
2013-01-18 18:14 EST, Dan Pascu
no flags Details
File: open_fds (632 bytes, text/plain)
2013-01-18 18:14 EST, Dan Pascu
no flags Details
File: proc_pid_status (782 bytes, text/plain)
2013-01-18 18:14 EST, Dan Pascu
no flags Details
File: var_log_messages (300 bytes, text/plain)
2013-01-18 18:14 EST, Dan Pascu
no flags Details

  None (edit)
Description Dan Pascu 2013-01-18 18:13:31 EST
Description of problem:
I had just installed the Fritzing package (fritzing.i686 0.7.5b-2.fc18 as displayed) using yum, on a fresh install of Fedora 18, from the Fedora repo. 
When I try to add any component, or sometimes just click anywhere in the Fritzing window, it crashes.

I had the same problem with Fritzing in Fedora 17.

To reproduce:
1. Fresh install Fedora 18 
2. Update system
3. Install Fritzing
4. Run Fritzing and try to add any component

P.S. Fritzing 0.7.10b downloaded from the project's web page works ok.

Version-Release number of selected component:
fritzing-0.7.5b-2.fc18

Additional info:
backtrace_rating: 4
cmdline:        Fritzing
crash_function: QMetaObject::activate
executable:     /usr/bin/Fritzing
kernel:         3.7.2-201.fc18.i686.PAE
remote_result:  NOTFOUND
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 QMetaObject::activate at kernel/qobject.cpp:3441
 #1 QStatusBar::messageChanged at .moc/release-shared/moc_qstatusbar.cpp:145
 #2 QStatusBar::hideOrShow at widgets/qstatusbar.cpp:696
 #3 QStatusBar::showMessage at widgets/qstatusbar.cpp:616
 #4 message at widgets/qstatusbar.h:88
 #5 qt_static_metacall at .moc/release-shared/moc_qstatusbar.cpp:67
 #6 QStatusBar::qt_static_metacall at .moc/release-shared/moc_qstatusbar.cpp:57
 #7 QMetaObject::activate at kernel/qobject.cpp:3539
 #8 QStatusBar::messageChanged at .moc/release-shared/moc_qstatusbar.cpp:145
 #9 QStatusBar::hideOrShow at widgets/qstatusbar.cpp:696
Comment 1 Dan Pascu 2013-01-18 18:13:49 EST
Created attachment 682791 [details]
File: backtrace
Comment 2 Dan Pascu 2013-01-18 18:13:51 EST
Created attachment 682792 [details]
File: cgroup
Comment 3 Dan Pascu 2013-01-18 18:13:56 EST
Created attachment 682793 [details]
File: core_backtrace
Comment 4 Dan Pascu 2013-01-18 18:13:58 EST
Created attachment 682794 [details]
File: dso_list
Comment 5 Dan Pascu 2013-01-18 18:14:00 EST
Created attachment 682795 [details]
File: environ
Comment 6 Dan Pascu 2013-01-18 18:14:02 EST
Created attachment 682796 [details]
File: limits
Comment 7 Dan Pascu 2013-01-18 18:14:05 EST
Created attachment 682797 [details]
File: maps
Comment 8 Dan Pascu 2013-01-18 18:14:07 EST
Created attachment 682798 [details]
File: open_fds
Comment 9 Dan Pascu 2013-01-18 18:14:09 EST
Created attachment 682799 [details]
File: proc_pid_status
Comment 10 Dan Pascu 2013-01-18 18:14:11 EST
Created attachment 682800 [details]
File: var_log_messages
Comment 11 Ed Marshall 2013-01-18 18:52:28 EST
This is a known bug, and version 0.7.11b is slated to go out as a stable release in F18 shortly. You can pull it in by enabling the updates-testing repo if you'd like to work with it sooner than that.

Thanks for the report!

*** This bug has been marked as a duplicate of bug 852568 ***

Note You need to log in before you can comment on or make changes to this bug.