Bug 901917 - rescue a fedora system mode doesn't recognize luks installation
rescue a fedora system mode doesn't recognize luks installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker AcceptedFreezeException
:
: 908118 (view as bug list)
Depends On:
Blocks: F20AlphaFreezeException F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-01-19 18:18 EST by James
Modified: 2013-10-08 08:13 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-20.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 08:13:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2013-01-19 18:18:35 EST
Description of problem:
the rescue option of the fedora 18 install dvd does not recognize a luks encrypted installation, it does not setup and mount automatically

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install fedora 18 encrypted
2. boot into rescue mode of the install dvd
3.
  
Actual results:
anaconda says it does not find a linux system

Expected results:
anaconda sets up the luks patition automatically

Additional info:
Comment 1 Peter Bieringer 2013-01-20 14:15:53 EST
Can confirm the issue
Comment 2 Peter Bieringer 2013-01-20 16:58:53 EST
Ugly workaround: boot in rescue mode, skip anaconda step, do all manually on shell, e.g.
search with "blkid" for encrypted partition, open it with "cryptsetup luksOpen /dev/something", start VolumeGroup by "vgchange -a y". Mount at least root partition to /mnt/sysimage, mount then (when existing) the /boot partion and /dev and /proc via bind mount. Then a "chroot" should be possible.
Comment 3 Stefan Becker 2013-06-28 11:41:56 EDT
Reproduced with F19.

This is *NASTY* beyond words. I consider this a showstopper bug, considering that users might be in "panic mode" when they have to use the rescue mode to revive their machine!

Example: a broken grub2 update, like bug 976768, where the machine doesn't even reach the grub menu anymore and rescue is your only option...


It seems to me that the new anaconda/anaconda storage module doesn't scan anything. Here is what I tried when the Continue/Read-Only/Skip dialog is up

- ALT-F2 to go into the shell
- run "cryptsetup open /dev/sda luks"
- verified that the unlocked partitions appear in /dev/mapper
- ALT-F1 to go back to dialog
- select "Continue"

Even now anaconda tells me that there are no Linux installations on the disk!


Note to self for future reference:

cryptsetup open /dev/sda luks
mount /dev/mapper/VolGroup00-LogVol00 /mnt/sysimage
mount /dev/sda1 /mnt/sysimage/boot
mount --bind /dev /mnt/sysimage/dev
mount --bind /proc /mnt/sysimage/proc
mount --bind /run /mnt/sysimage/run
mount --bind /sys /mnt/sysimage/sys
mount --bind /tmp /mnt/sysimage/tmp
chroot /mnt/sysimage
Comment 4 Stefan Becker 2013-08-20 11:48:27 EDT
Following the advice from #fedora-qa I'm assigning this as blocking bug to F20, so that it gets the proper attention (hopefully) in the F20 time frame.
Comment 5 Adam Williamson 2013-08-21 12:14:31 EDT
Discussed at 2013-08-21 blocker review meeting. This is rejected as an Alpha blocker but accepted as a Beta blocker: the Alpha criterion reads "The rescue mode of the installer must start successfully and be able to detect and mount an existing default installation." - https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Rescue_mode - and the Beta criterion reads "The rescue mode of the installer must be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations." - https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Rescue_mode - so that seems pretty clear.

Accepted as Alpha freeze exception issue too, as this is clearly something it'd be a good idea to fix if we can.
Comment 6 Tim Flink 2013-09-25 13:44:24 EDT
*** Bug 908118 has been marked as a duplicate of this bug. ***
Comment 7 Petr Schindler 2013-10-08 08:13:32 EDT
Bug is fixed in anaconda-20.21-1. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.