Bug 908118 - Rescue mode does not detect an encrypted Fedora installation
Rescue mode does not detect an encrypted Fedora installation
Status: CLOSED DUPLICATE of bug 901917
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F20BetaBlocker
  Show dependency treegraph
 
Reported: 2013-02-05 17:45 EST by Daniel Laczi
Modified: 2013-09-25 13:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 13:44:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Laczi 2013-02-05 17:45:14 EST
Description of problem:
The Fedora rescue mode shipped with the Fedora 18 installation media does not detect an encrypted Fedora installation.

Version-Release number of selected component (if applicable):
Fedora 18 x86_64 DVD (Release Version)

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora on an encrypted LVM
2. Boot from the installation media again and select "Rescue a Fedora system"
3. The rescue mode will not find the Fedora 18 system
  
Actual results:
An encrypted Fedora 18 installation is not being detected by system rescue and not mounted automatically to /mnt/sysimage.

Expected results:
As in Fedora 17 the system rescue mode in F18 should detect an encrypted Fedora system automatically. Detecting the F18 system with the F17 rescue mode works!

Additional info:
I have too "physical" partitions for Fedora on my HDD. One is for /boot the other for an encrypted LVM. Latter contains a logical volume for swap and one for /.
Comment 1 NM 2013-02-11 14:49:23 EST
I observed similar behaviour. 

I was able successfully use old FC16 rescue disk. It automatically prompted for the password and mounting file system under  /mnt/sysimage   as expected. 

Hope it helps.
Comment 2 Frank Murphy 2013-09-22 11:58:59 EDT
Didn't want to create new bz.

Also present in in F20 Alpha:
http://dl.fedoraproject.org/pub/alt/stage/20-Alpha-RC4/Fedora/x86_64/iso/Fedora-20-Alpha-x86_64-netinst.iso

Cannot find a fully updated F20.Xfce install
mix of mbr and gui partition types all luks, except boot.
Anaconda 20.18.1 from netinstall.
Comment 3 Andre Robatino 2013-09-22 13:29:43 EDT
Should this be a blocker?

https://fedoraproject.org/wiki/Fedora_20_Alpha_Release_Criteria#Rescue_mode : "The rescue mode of the installer must start successfully and be able to detect and mount an existing default installation." (I guess not, since encrypted isn't default.)

https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Rescue_mode : "The rescue mode of the installer must be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations."

It looks like it might be a Beta Blocker. The associated test case is

https://fedoraproject.org/wiki/QA:Testcase_Anaconda_rescue_mode

I test this on each compose, but normally only on an unencrypted minimal install, booting from the DVD (though it's just as easy to boot from the netinst, which I always have anyway).
Comment 4 Frank Murphy 2013-09-22 13:39:19 EDT
Probably not for Alpha, but Beta yes, as many still use luks.
I didn't have the chance to test rescue on F18\F19.
Comment 5 Andre Robatino 2013-09-22 13:43:37 EDT
Proposing as F20 Beta Blocker, and changing Version to 20.
Comment 6 Mike Ruckman 2013-09-25 12:18:56 EDT
Discussed this in 2013-09-25 Blocker Review Meeting [1]. While this could be a blocker, it isn't clear if nfs repos are working yet and only one is required to work for beta. Will revisit when we have more data on nfs repos.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
Comment 7 Mike Ruckman 2013-09-25 12:57:09 EDT
(In reply to Mike Ruckman from comment #6)
> Discussed this in 2013-09-25 Blocker Review Meeting [1]. While this could be
> a blocker, it isn't clear if nfs repos are working yet and only one is
> required to work for beta. Will revisit when we have more data on nfs repos.
> 
> [1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/

This is not the right bug for that comment. That was in reference to 1009809.

Sorry for the comment spam.
Comment 8 Mike Ruckman 2013-09-25 12:59:38 EDT
Discussed in the 2013-09-25 Blocker Review Meeting [1]. Acknowledged as an AcceptedBlocker - Violates the following F20 beta criterion for systems with encrypted partitions: "The rescue mode of the installer must be able to detect and mount any installation performed according to the applicable criteria, and provide a shell with access to utilities capable of performing typical recovery operations." [2]

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-09-25/
[2] https://fedoraproject.org/wiki/Fedora_20_Beta_Release_Criteria#Rescue_mode
Comment 9 Tim Flink 2013-09-25 13:44:24 EDT
This seems to be a duplicate of 901917 which is already POST. Closing.

*** This bug has been marked as a duplicate of bug 901917 ***

Note You need to log in before you can comment on or make changes to this bug.