Bug 90193 - M-<, M-> don't set mark?
Summary: M-<, M-> don't set mark?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
: 102441 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-05-05 09:35 UTC by Jonathan Kamens
Modified: 2015-01-08 00:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 15:02:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2003-05-05 09:35:04 UTC
With emacs-21.3-3, if I start emacs, type some text, type M-<, and then type
C-w, it beeps and says, "The mark is not active now."  This behavior was not
present in emacs-21.3-1.  I traced it to the fact that transient-mark-mode is
set to true in default.el.

Perhaps this is a bug in transient-mark-mode; the description of the variable
certainly doesn't imply that this behavior should occur.  In this case, I
suppose you should report it upstream.

Independent of that, I don't think it's appropriate for Red Hat to set
transient-mark-mode in default.el.  It's a personal user preference, and I
believe the default should be left as shipped by the FSF.

Comment 1 Jens Petersen 2003-05-07 12:51:35 UTC
The behaviour is better documented in the emacs info manual.

However I agree forcing this on old users is perhaps not right.
I can either move it back into "/etc/skel/.emacs" and make it a
defvar instead so that it is easy for experienced users to override
it in their own .emacs file.

Comment 2 Jens Petersen 2003-05-07 12:59:47 UTC
I meant "... OR make it a defvar..."

Comment 3 Jens Petersen 2003-05-20 03:59:50 UTC
Btw if you don't want to use the settings in "default.el" you know you
can also set "(setq inhibit-default-init t)" in your .emacs file.

Comment 4 Jens Petersen 2004-01-15 01:29:47 UTC
In emacs-21.3-8 I commenting out transient-mark-mode
in the .emacs skel file too.

Comment 5 Jens Petersen 2004-04-15 15:01:40 UTC
*** Bug 102441 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.