Bug 902275 - F-18 Disk Partitioner cannot reuse partitions
F-18 Disk Partitioner cannot reuse partitions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 04:50 EST by business.kid
Modified: 2013-04-02 14:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-02 14:39:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Install dialogues (65.70 KB, image/png)
2013-01-24 07:02 EST, business.kid
no flags Details
Install dialogues (64.00 KB, image/png)
2013-01-24 07:08 EST, business.kid
no flags Details
Install log files, screenshots, system fstab (153.41 KB, application/octet-stream)
2013-01-24 15:20 EST, business.kid
no flags Details
anaconda.log (33.68 KB, text/plain)
2013-01-24 17:14 EST, Steve Tyler
no flags Details
program.log (101.16 KB, text/plain)
2013-01-24 17:14 EST, Steve Tyler
no flags Details
storage.log (329.08 KB, text/plain)
2013-01-24 17:15 EST, Steve Tyler
no flags Details
Screenshot from 2013-01-24 14:42:56.png (55.60 KB, image/png)
2013-01-24 17:19 EST, Steve Tyler
no flags Details
Screenshot from 2013-01-24 14:43:17.png (59.04 KB, image/png)
2013-01-24 17:19 EST, Steve Tyler
no flags Details
Slackware-14.0 /etc/fstab (785 bytes, application/octet-stream)
2013-01-25 04:34 EST, business.kid
no flags Details
My Workaround for this issue. (46.85 KB, image/png)
2013-01-25 13:21 EST, business.kid
no flags Details
screenshot showing "/fedora" on sda5 under "Unknown Linux" (72.95 KB, image/png)
2013-01-25 16:07 EST, Steve Tyler
no flags Details
screenshot showing "/" on sda5 under "New Fedora 18 Installation" (76.63 KB, image/png)
2013-01-25 16:08 EST, Steve Tyler
no flags Details
screenshot showing slackware root mount point configuration (11.13 KB, image/png)
2013-01-25 16:26 EST, Steve Tyler
no flags Details

  None (edit)
Description business.kid 2013-01-21 04:50:37 EST
Description of problem: I can't install F18 Electronic Spin because  the installer does not allow me to use the existing partitions


Version-Release number of selected component (if applicable): 18 Electronic Spin


How reproducible:


Steps to Reproduce:
1.Install any other system with /boot, swap, /, & /home partitions
2.Provide one extra partition for Fedora /
3.Try to install on it!
  
Actual results:
Even using the "I'll do it myself!" option The installer insists on choosing for you and it is impossible to reuse /boot, swap, or /home partitions. 

Expected results:
Install without a fight

Additional info: I have a 60G SSD, (while people sort out UEFI booting) set uo as follows
sda1 - 100MB common /boot
sda2 - 6G - common swap
sda3 ~ 15G Slackware /
sda4 - Ext.
sda5 - 15G blank for Fedora
sda6 - rest (20G) common /home

/boot is thrown out also because the minimum acceptable size is 500MB :-O? 50MB would do! The disk partitioner will not reuse /home, or swap, to my amazement. My home dir is 6.1G, down now from ~12G, and no photos, music or videos are included. Am I supposed to duplicate all that stuff? Slackware's user is 1000:100 and fedora uses 500:500. A quick usermod allows the same directory to be used by each user. This is not a problem as Slackware's XFCE is very non invasive in the home dir. I think the biggest penalty may be a few useless icons on the desktop. This thread refers
http://www.linuxquestions.org/questions/fedora-installation-39/disk-partitioning-question-f-18-a-4175446373/
Comment 1 Chris Lumens 2013-01-22 14:44:07 EST
Er, yes, we do let you reuse filesystems.  You select the disks you want to include as part of the installation, go into custom partitioning, select the filesystems from the left hand side, and assign them mount points on the right hand side.  This is also explained in the help text on the custom partitioning.  You should absolutely be able to do what you're wanting to do, but it's very hard to say what's happened given the lack of details here.
Comment 2 Steve Tyler 2013-01-22 17:53:28 EST
(In reply to comment #0)
...
> /boot is thrown out also because the minimum acceptable size is 500MB :-O?
> 50MB would do!
...

I just did a minimal install in a VM using Manual Partitioning and was able to reuse a 100 MB /boot that was part of a previously installed F18 installation. Did you get an error message saying 500 MB was required?

Could you attach a screenshot showing the Manual Partitioning dialog?

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-DVD.iso -vga qxl -boot menu=on -usbdevice mouse
Comment 3 business.kid 2013-01-23 05:46:46 EST
Comparing your results with mine, I think it's that I get sent into the "Reclaim Space" dialogue, and THERE I can't reuse disks. Have a look at these screenshots (Best I could manage - Camera recently knackered & phone is old).

https://skydrive.live.com/#cid=9936144096FF2C07&id=9936144096FF2C07!208

I have installed at least 12 flavours of linux since 1993. I'm no newbie. Look particular at sda5 in the output below (temporarily mounted on /fedora)

bash-4.2# fdisk -l
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048      206847      102400   83  Linux
/dev/sda2          206848    12881919     6337536   82  Linux swap
/dev/sda3        12881920    44582911    15850496   83  Linux
/dev/sda4        44582912   117229567    36323328    5  Extended
/dev/sda5        44584960    76271615    15843328   83  Linux
/dev/sda6        76273664   117229567    20477952   83  Linux
bash-4.2# df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda3        15G  8.3G  5.9G  59% /
/dev/sda1        97M   25M   67M  28% /boot
/dev/sda6        20G  5.5G   13G  30% /home
tmpfs           2.9G     0  2.9G   0% /dev/shm
/dev/sda5        15G  166M   14G   2% /fedora

Now compare that with the photos.There is a 16k lost+found dir and NOTHING else on sda5, which is newly created. Your disk dialog insists it's full! I think that's the first bug. Try reusing space from the 'reclaim space' dialog!

On a side note, I've been installing linux since 1993, used over a dozen disk partitioning systems, and that one is about the worst I can remember. Who thought up grey buttons hidden in screen corners on a grey background as a colour scheme? Was he smoking a banned substance? Why do you always choose tiny fonts? and while I'm venting, can't you do something about the CD? The poor cd drive seeks from one end to the other continually, for one sector. Then back off to the other end for the next sector. It was faster booting the old IBM XT @4.77 Mhz - memory test and all!!
Comment 4 Steve Tyler 2013-01-23 07:20:13 EST
OK, thanks. Checking the box for "I don't need help; let me customize disk partitioning." and then clicking "Reclaim space" will get you to the Manual Partitioning dialog.

Here are two bug reports about the dialog in your screenshots:
Bug 876091 - Can not use free space to partition 
Bug 876916 - anaconda claims I don't have enough free space when I have
Comment 5 Steve Tyler 2013-01-23 08:20:08 EST
BTW, you can install Live images to a USB stick -- running from a USB stick is much faster than running from an optical disc. See "man livecd-iso-to-disk".
Comment 6 business.kid 2013-01-23 09:09:06 EST
Great - So you can mark this as a duplicate of both, and close it. I see the need to spoonfeed software guys when I have the problem and they don't but it is time consuming. Kindly don't include me on the cc - some of these last and last.
I take it you are trying to manage the situation after the last team leader was fired / transferred / sent to a home for the bewildered. In case it hasn't been mentioned to you, this may be relevant on the installer's many issues.

http://www.dedoimedo.com/computers/fedora-18-kde.html
Comment 7 Chris Lumens 2013-01-23 09:56:01 EST
> Great - So you can mark this as a duplicate of both, and close it. I see the
> need to spoonfeed software guys when I have the problem and they don't but
> it is time consuming. Kindly don't include me on the cc - some of these last
> and last.
> I take it you are trying to manage the situation after the last team leader
> was fired / transferred / sent to a home for the bewildered. In case it
> hasn't been mentioned to you, this may be relevant on the installer's many
> issues.
> 
> http://www.dedoimedo.com/computers/fedora-18-kde.html

And you can dispense with the attitude and "clever" comments, because it does nothing to help us fix your bugs.  All it's going to result in is you being ignored in the future.

You don't use the reclaim dialog to reuse existing partitions.  You use it to reclaim space such that we can do autopartitioning.  If you want to reuse existing partitions, you need to go into custom partitioning.
Comment 8 business.kid 2013-01-23 11:17:39 EST
Look, insulting never helps and if I'm coming over that way, I apologise. 
That said, the software is a problem. 'man livecd-iso-to-disk' doesn't exist on the live cd, or anything like it or a binary by that name.

Reclaim space as a separate dialogue is going to confuse people, and they will run scared of that idea as I do. Relabel the button "Continue with install" and you'll save a lot of headaches.

So I tried to circumnavigate the 'empty space not seen' bug and hit another. I "deleted" sda5 (15G) which was seen as full, and returned to the install. I was then told "You now have loads of space ti install Fedora."

The only option I was offered for / was sda6 (greyed out from what I could judge). It had all the partitions in use mixed up and would not allow me to fix it. You really will have to do something about the 'grey on same grey' colour scheme. I could not select sda5 as a / partition. There may be some way to do it. I really don't care anymore.

As for the iso on USB, Samsung, in their infinite wisdom removed usb booting from the model NP350E7C-A05UK. I can boot UEFI on gpt disks, or mbr on mbr disks with Secure boot turned off, It's actually still on for gpt disks. CD Boot is only available with secure boot off. Fortunately, windows 8 is so bad it's going to bomb much worse than vista. 

Thanks for all the help[ offered, which I appreciate. I'm voting with my feet over the installer.
Comment 9 Steve Tyler 2013-01-23 17:11:39 EST
(In reply to comment #8)
...
> The only option I was offered for / was sda6 (greyed out from what I could
> judge). It had all the partitions in use mixed up and would not allow me to
> fix it. You really will have to do something about the 'grey on same grey'
> colour scheme. I could not select sda5 as a / partition. There may be some
> way to do it. I really don't care anymore.
...

Could you attach a screenshot showing this? Please attach it using the "Add an attachment" link at the top of this bug report, so that it doesn't get lost in cyberspace. You can get a screenshot while running the Live image by pressing PrintScrn. The file is saved in ~/Pictures.

And if you can find a computer that supports USB booting ...

3.2.2.2. Making Fedora USB Media in other Linux Distributions
http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/Making_USB_Media-UNIX_Linux-other.html

NB: livecd-iso-to-disk an "--efi" option.
Comment 10 business.kid 2013-01-24 07:02:12 EST
Created attachment 686686 [details]
Install dialogues
Comment 11 business.kid 2013-01-24 07:08:51 EST
Created attachment 686697 [details]
Install dialogues

These highlight what is to my mind the BIGGEST problem with this installer. It has to be _blindingly_obvious_ to the user what the consequences of his actions are going to be. Here I have sda6 (/home, 20G) picked up as the now empty sda5 and vice versa.

I object to this being closed as NOTABUG, although I can see the wisdom in limiting total bug numbers. I would be quite happy with DUPLICATE, but we are talking about real malfunctions and to close this as NOTABUG is simply not accurate.

Path there, btw was install to hd, reclaim space, install to hd, standard partitions (Not LVM) and any option after that.
Comment 12 Steve Tyler 2013-01-24 09:58:45 EST
Thanks for the additional info. I'm not sure how the installer analyzes Unknown Linux installations, but it appears to be getting confused by the slackware installation. Developers are going to need to see the installer log files to figure out what is going wrong.

Could you attach these installer logs from /tmp as separate text/plain files?
/tmp/anaconda.log
/tmp/program.log
/tmp/storage.log
Comment 13 Steve Tyler 2013-01-24 10:02:29 EST
What version of slackware do you have installed?
Comment 14 business.kid 2013-01-24 15:20:11 EST
Created attachment 686974 [details]
Install log files, screenshots, system fstab

Here you have 
1. Requested install logs (I removed ifcfg.log as it has my password, I presume)
2. 2 Screenshots showing the incorrect disk assignment
3. /etc/fstab from the Slackware-14.0 installation.

I am quite familiar with the partitions. sda5 is 15G and I intended that for fedora root. sda6 is 20Gig and is /home in slackware, and home for fedora as well, but therein lies the problem. It's stalemate.
It's positively scary to have a resize dialogue so handy, as people will move it by mistake. Much better to have it in a separate screen.

Given that I know a certain amount, can I just mount sda5, for example
mount /dev/sdfa5 /fedora
cd to the RPMS dir and run something like

rpm -ivh --nodeps --root=/fedora  *.rpm ?? It's been a long time since I saw the rpm man page but you get the idea? I would have to tidy up in /etc, but that's doable for someone with 20 years at this, and a working /etc to go from.
Comment 15 business.kid 2013-01-24 15:22:58 EST
Slackware-14.0, btw. And I'm using an SSD, which gives 450MB/S and may be a cause of timing issues. It already caught out the foo2zjs printing program - things camne back too fast.
Comment 16 business.kid 2013-01-24 15:24:30 EST
Slackware-14.0, btw. And I'm using an SSD, which gives 450MB/S and may be a cause of timing issues. It already caught out the foo2zjs printing program - things camne back too fast.
Comment 17 Steve Tyler 2013-01-24 17:14:29 EST
Created attachment 687041 [details]
anaconda.log
Comment 18 Steve Tyler 2013-01-24 17:14:58 EST
Created attachment 687042 [details]
program.log
Comment 19 Steve Tyler 2013-01-24 17:15:27 EST
Created attachment 687043 [details]
storage.log
Comment 20 Steve Tyler 2013-01-24 17:19:35 EST
Created attachment 687044 [details]
Screenshot from 2013-01-24 14:42:56.png
Comment 21 Steve Tyler 2013-01-24 17:19:59 EST
Created attachment 687045 [details]
Screenshot from 2013-01-24 14:43:17.png
Comment 22 Steve Tyler 2013-01-24 17:27:52 EST
Thanks for the logs.

The tar file did not have fstab. Could you post it as a comment or attach it as a text/plain file?

In the future, please attach logs as separate files, so they can be opened in the browser and searched from BZ. BZ usually sets the wrong MIME type for text files, so the MIME type has to be explicitly set to text/plain.
Comment 23 Steve Tyler 2013-01-24 17:41:09 EST
Since you have provided new information, I believe this bug can be reopened. You can reopen it by changing the status at the bottom of this bug page from CLOSED to ASSIGNED.
Comment 24 business.kid 2013-01-25 04:34:13 EST
Created attachment 687348 [details]
Slackware-14.0 /etc/fstab

Attached /etc/fstab from Slackware-14.0, the other system on this box. I had a line in there

sda5 /fedora  ext4  options, etc

and pulled it as the system was picking /fedora up as a data partition in the old system. Your installer is spotting the 1.86MB unassigned space in 60G, so that rules out fdisk & df as sources of information. Maybe some console invokation of parted?
Comment 25 Steve Tyler 2013-01-25 11:46:23 EST
I cannot reproduce this problem after installing slackware 14 to a 12 GiB VM disk image that was pre-partitioned with the F18 gparted. In the Manual Partitioning dialog, the installer lists sda6 (slackware /home) as Home under "Unknown Linux" and sda5 (formatted but empty) is listed under "Unknown".

Further, I could add /boot and /home to the new installation without formatting. I added sda5 as "/" to the new installation with formatting. Swap was automatically reused. I did not attempt to actually install.

This all works as expected.

The following was captured while running the F18 Live image:

[root@localhost ~]# parted /dev/sda u mib p free
Model: ATA QEMU HARDDISK (scsi)
Disk /dev/sda: 12288MiB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start     End       Size     Type      File system     Flags
        0.03MiB   1.00MiB   0.97MiB            Free Space
 1      1.00MiB   101MiB    100MiB   primary   ext4
 2      101MiB    601MiB    500MiB   primary   linux-swap(v1)
 3      601MiB    5601MiB   5000MiB  primary   ext4
 4      5601MiB   12288MiB  6687MiB  extended
 5      5602MiB   9602MiB   4000MiB  logical   ext4
 6      9603MiB   10603MiB  1000MiB  logical   ext4
        10603MiB  12288MiB  1685MiB            Free Space

[root@localhost ~]# cat /mnt/slack-test-1-root/etc/fstab
/dev/sda2        swap             swap        defaults         0   0
/dev/sda3        /                ext4        defaults         1   1
/dev/sda1        /boot            ext4        defaults         1   2
/dev/sda6        /home            ext4        defaults         1   2
#/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro,comment=x-gvfs-show 0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
[root@localhost ~]# 

Tested with:
$ qemu-img create slack-test-1.img 12G
$ qemu-kvm -m 2048 -hda slack-test-1.img -cdrom slackware64-14.0-install-dvd.iso -vga qxl -boot menu=on -usbdevice mouse
$ qemu-kvm -m 2048 -hda slack-test-1.img -cdrom ~/xfr/fedora/F18/F18-Final/Final/Fedora-18-x86_64-Live-Desktop.iso -vga qxl -boot menu=on -usbdevice mouse
Comment 26 business.kid 2013-01-25 13:21:47 EST
Created attachment 687611 [details]
My Workaround for this issue.

Attached my workaround for the moment. I found my F-17 dvd and installed that. sda5 is 15G and sda6 is /home and 20G. Install was painless. If there's an updated installer you want me to try let me know, and how. Downgrading it looks like a mighty good idea from here. The built in screenshot 'camera' is a really nifty feature. Pity the file names are so unix unfriendly.
Comment 27 Steve Tyler 2013-01-25 14:48:59 EST
I reproduced the partition renumbering problem.

Click "-" to remove sda5 under "Unknown".
Click "+" to add "/".

Under "New Fedora 18 Installation", "/" is on sda6.
Under "Unknown Linux", "/home" is now on sda5.

To retain the partition numbering, sda5 must be reformatted, not removed.
Comment 28 David Lehman 2013-01-25 15:39:53 EST
(In reply to comment #24)
> Created attachment 687348 [details]
> Slackware-14.0 /etc/fstab
> 
> Attached /etc/fstab from Slackware-14.0, the other system on this box. I had
> a line in there
> 
> sda5 /fedora  ext4  options, etc
> 
> and pulled it as the system was picking /fedora up as a data partition in
> the old system. Your installer is spotting the 1.86MB unassigned space in
> 60G, so that rules out fdisk & df as sources of information. Maybe some
> console invokation of parted?

You shouldn't use names like /dev/sda5 in /etc/fstab or /etc/crypttab for exactly this reason -- they can change unexpectedly. You should instead use blkid to determine the UUID of the filesystem you want to mount and specify the device that way, eg: 'UUID=asdfasdf-w45twgw-ww5gw5g' instead of '/dev/sda3'.

The rules for logical partitions are that removing one causes any and all others with higher numbers to be renumbered accordingly since there cannot be empty/unused logical partition slots like there can for primary partitions. More simply stated, the first logical partition is always sda5. Removing sda5 makes sda6 get renumbered to sda5.
Comment 29 Steve Tyler 2013-01-25 16:07:16 EST
Created attachment 687680 [details]
screenshot showing "/fedora" on sda5 under "Unknown Linux"

I also tried adding an entry to /etc/fstab for sda5 mounted on "/fedora" in slackware. With that change, the installer lists "/fedora" under "Unknown Linux".

From Manual Partitioning, by marking sda5 for reformatting and setting its mount point to "/", I could add it to "New Fedora 18 Installation". As before, "/boot" and "/home" could be reused without reformatting, and swap was reused automatically.

The problem that I have noticed while testing this is that there is no user feedback when a device is added to "New Fedora 18 Installation" without reformatting, because that list and the "Unknown Linux" list cannot both be expanded at the same time.

NB: I have been clicking "Apply Changes" after configuring each device. The lack of user feedback is apparent when, after clicking "Apply Changes", nothing seems to have changed, if the device is being reused without reformatting.
Comment 30 Steve Tyler 2013-01-25 16:08:56 EST
Created attachment 687682 [details]
screenshot showing "/" on sda5 under "New Fedora 18 Installation"
Comment 31 Steve Tyler 2013-01-25 16:26:15 EST
Created attachment 687683 [details]
screenshot showing slackware root mount point configuration

For the record, the slackware installer (called "setup") configures devices in /etc/fstab by device name.
Comment 32 business.kid 2013-01-26 05:03:25 EST
Steve, you have obviously gone to a great deal of bother duplicating my system here to reproduce this. The points you make about lack of feedback are the telling ones to me. It has to be blindingly obvious what's going on before a user will proceed. He'd deleting his own partitions, for heaven's sakes! On the list of things that make people paranoid, is there anything above that?
I accept that blkids are better than /dev/whatsit where multiple systems are reading each other's files. I avoid them because they deny the user the information required - i.e. what partition are we talking about? As I think in /dev/sdax and not blkids, it's easier - usually.

So the real problems are
1. a 15G sda5 is seen as full when it's empty.
2. There is poor feedback, so the first time installer (= all of us, as this installer is new) hasn't a clue. what's going on.
Comment 33 business.kid 2013-01-26 15:06:35 EST
I had one more go at this, largely because F-17 was panicking with "unknown option root=805" when root was definitely NOT set to 805 :-(. 

I tried (as root
dd if=/dev/zero of=/dev/sda5, destroying F17 and the ext4 partition. I was still told 1.86MB free and my only option was "Reclaim space." When I give a middle finger to your automatic partitioning, and say "I'll sort this out," I NEED TO BE ALLOWED SORT IT OUT. Unfortunately, I'm not. It was still thinking for me and would only allow "Reclaim space."

That 1.86MB free in in 2 chunks, and is the total to ends of 'cylinders' in this ssd. I can't make a 1.86MB partition. I'd watch that.   parted is the only thing that gives that info. You're manipulating a parted shell - no wonder this thing is crazy. 
Once I realised that, I called on LFS Experience, & I installed F-18 from Slackware as follows:
mount -o loop /mnt/cdrom/LiveOS/squashfs.img /mnt/tmp
mount -o loop /mnt/tmp/LiveOS/ext3fs.img /mnt/hd
mke2fs -j -t ext4 /dev/sda5
mount /dev/sda5 /fedora
cd /fedora
cp -a /mnt/hd/* . && sync

Now, of course, it's all jammy side down and I'll have to set it up, but I'll get going. I have _never_ had to do anything like that with a distro before.

Note You need to log in before you can comment on or make changes to this bug.