Bug 902397 - Corosync doesn't work with IPv6
Summary: Corosync doesn't work with IPv6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: corosync
Version: 6.4
Hardware: All
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks: 905536
TreeView+ depends on / blocked
 
Reported: 2013-01-21 15:06 UTC by Jan Friesse
Modified: 2013-02-21 07:51 UTC (History)
4 users (show)

Fixed In Version: corosync-1.4.1-15.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 07:51:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
Proposed patch (1.12 KB, patch)
2013-01-21 15:06 UTC, Jan Friesse
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0497 normal SHIPPED_LIVE corosync bug fix and enhancement update 2013-02-20 21:18:24 UTC

Description Jan Friesse 2013-01-21 15:06:28 UTC
Created attachment 684367 [details]
Proposed patch

Description of problem:
Patch in https://bugzilla.redhat.com/show_bug.cgi?id=821352 contained regression which makes corosync not working at all with IPv6

Version-Release number of selected component (if applicable):
Starting from 1.4.1-8

How reproducible:
100%

Steps to Reproduce:
1. Configure ipv6 (for example ifconfig eth0 add fd00::1/8)
2. Configure corosync to use ipv6 (for example

# Please read the corosync.conf.5 manual page
totem {
version: 2

secauth:off
nodeid: 2
interface {
ringnumber: 0
bindnetaddr: fd00::1
mcastaddr: ff3e::4321:1234
mcastport: 5405
ttl: 1
}
}

logging {
fileline: off
to_stderr: yes
to_logfile: yes
logfile: /var/log/cluster/corosync.log
to_syslog: yes
debug: on
}

3. Start corosync
  
Actual results:
corosync [TOTEM ] Initializing transmit/receive security: libtomcrypt SOBER128/SHA1HMAC (mode 0).
corosync [IPC   ] you are using ipc api v2
corosync: totemsrp.c:4503: main_iface_change_fn: Assertion `instance->my_id.addr[iface_no].nodeid' failed.
corosync [TOTEM ] The network interface is down.
Aborted


Expected results:
corosync [TOTEM ] Local transmit multicast loop socket send buffer size (262142 bytes).
corosync [TOTEM ] The network interface [fd00::1] is now up.


Additional info:

Comment 9 errata-xmlrpc 2013-02-21 07:51:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0497.html


Note You need to log in before you can comment on or make changes to this bug.