Bug 902451 - RFE: multiple ops on resource creation time
Summary: RFE: multiple ops on resource creation time
Keywords:
Status: CLOSED DUPLICATE of bug 912496
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs
Version: 6.4
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-21 17:34 UTC by Jaroslav Kortus
Modified: 2013-08-13 23:44 UTC (History)
3 users (show)

Fixed In Version: pcs-0.9.64-1.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-13 23:44:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jaroslav Kortus 2013-01-21 17:34:07 UTC
Description of problem:
Please update pcs so that the following works:

pcs resource create dummystateful ocf:pacemaker:Stateful op monitor interval="30s" op monitor role="Slave" interval="33s"

Version-Release number of selected component (if applicable):


Expected results:
Two operations as described in the command, as if they were added one after another.

Comment 3 Chris Feist 2013-03-13 21:27:18 UTC
This has been committed upstream (and should be part of the 6.5 resync)

https://github.com/feist/pcs/commit/a491078ebbc76019bd218b454edc2ad056edbae8

Comment 4 Chris Feist 2013-08-13 21:18:28 UTC

[root@ask-02 ~]# rpm -q pcs
pcs-0.9.64-1.el6.noarch
[root@ask-02 ~]# pcs -f test.xml resource create Test Dummy op monitor interval=30s op monitor interval=31s
[root@ask-02 ~]# pcs -f test.xml resource show Test
 Resource: Test (class=ocf provider=heartbeat type=Dummy)
  Operations: monitor interval=30s (Test-monitor-interval-30s)
              monitor interval=31s (Test-monitor-interval-31s)

Comment 5 Chris Feist 2013-08-13 21:33:58 UTC
*** Bug 912496 has been marked as a duplicate of this bug. ***

Comment 6 Chris Feist 2013-08-13 23:44:06 UTC

*** This bug has been marked as a duplicate of bug 912496 ***


Note You need to log in before you can comment on or make changes to this bug.