Bug 912496 - Allow multiple 'op' options when creating a resource
Summary: Allow multiple 'op' options when creating a resource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs
Version: 6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Chris Feist
QA Contact: Cluster QE
URL:
Whiteboard:
: 902451 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-02-18 20:03 UTC by Chris Feist
Modified: 2013-11-21 11:51 UTC (History)
6 users (show)

Fixed In Version: pcs-0.9.64-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: Multiple resource operations could not be specified when creating a resource Consequence: Only resources with one operation could be created Fix: 'pcs resource create' was updated to allow multiple operations to be created with a resource Result: Users can now create resources with multiple operations
Clone Of:
Environment:
Last Closed: 2013-11-21 11:51:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1633 normal SHIPPED_LIVE pcs bug fix and enhancement update 2013-11-20 21:53:48 UTC

Description Chris Feist 2013-02-18 20:03:15 UTC
Description of problem:
Currently it isn't possible to specify multiple 'op' options when creating a resource with pcs.

Version-Release number of selected component (if applicable):
pcs-0.9.26-10.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. pcs resource create test_res IPaddr2 ip="192.168.0.1" op start interval="0" timeout="20s" op stop interval="0" timeout="20s"
  
Actual results:
Only one operation is created

Expected results:
Both operations are created

Comment 8 Chris Feist 2013-08-13 21:33:58 UTC

*** This bug has been marked as a duplicate of bug 902451 ***

Comment 10 Chris Feist 2013-08-13 23:44:06 UTC
*** Bug 902451 has been marked as a duplicate of this bug. ***

Comment 14 errata-xmlrpc 2013-11-21 11:51:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1633.html


Note You need to log in before you can comment on or make changes to this bug.