Bug 902506 - Cluster->Services tab does not display list of Servers when it should
Cluster->Services tab does not display list of Servers when it should
Status: CLOSED DUPLICATE of bug 885592
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Shireesh
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-21 14:41 EST by Matt Mahoney
Modified: 2013-07-03 02:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-22 00:33:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cluster Services Tab (134.28 KB, image/png)
2013-01-21 14:42 EST, Matt Mahoney
no flags Details

  None (edit)
Description Matt Mahoney 2013-01-21 14:41:34 EST
Description of problem:
After adding two servers to a cluster, and the clicking on the cluster->services tab; the servers were expected to be listed but are not

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create cluster
2. Add one or more servers to cluster
3. navigate to the cluster->services tab
  
Actual results:
No servers listed in cluster->services tab.

Expected results:
Existing servers should be listed in cluster->servers tab.

Additional info:
Comment 1 Matt Mahoney 2013-01-21 14:42:24 EST
Created attachment 684601 [details]
Cluster Services Tab
Comment 2 Matt Mahoney 2013-01-21 14:43:14 EST
This was encountered in RHS-C QA4.
Comment 6 Shireesh 2013-01-22 00:33:45 EST
The NFS and SHD services are fetched using the 'gluster volume status' command. Again, NFS status is fetched by executing the command on a volume that is exported through NFS, and SHD from a volume that is of type replicate or distributed replicate. If you don't have any volumes of these types, you will not see any services.

Having said this, currently there is an open BUG (Bug 885592) related to this. The fix for that bug will ensure that above logic is implemented properly. So marking this as a duplicate.

*** This bug has been marked as a duplicate of bug 885592 ***

Note You need to log in before you can comment on or make changes to this bug.