Bug 902677 - Miss /etc/init.d/rpcbind service in rhev-h 6.4.
Miss /etc/init.d/rpcbind service in rhev-h 6.4.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression, TestBlocker
: 869956 902230 912933 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 03:47 EST by haiyang,dong
Modified: 2013-04-08 08:50 EDT (History)
17 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-16.el6
Doc Type: Bug Fix
Doc Text:
The rpcbind service was previously removed from Red Hat Enterprise Virtualization Hypervisor to prevent hypervisor nodes from being used as NFS servers. The rpcbind service is required for a hypervisor node to mount NFS shares, and was added back.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:47:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-01-22 03:47:11 EST
Description of problem:
Clean install rhev-h, Press "F2" to drop into Shell, then
[root@dhcp-8-185 admin]# mount -t nfs 10.66.90.115:/vol/S1/cshao_data /mnt
mount.nfs: rpc.statd is not running but is required for remote locking.
mount.nfs: Either use '-o nolock' to keep locks local, or start statd.
mount.nfs: an incorrect mount option was specified
[root@dhcp-8-185 admin]# service rpcbind status
rpcbind: unrecognized service
[root@dhcp-8-185 admin]# /etc/init.d/rpc
rpcgssd     rpcidmapd   rpcsvcgssd  

So the rhev-h 6.4 missed /etc/init.d/rpcbind service

No this issue on build rhev-hypervisor6-6.3-20121212.0.el6_3:
[root@localhost admin]# mount -t nfs 10.66.90.115:/vol/S1/cshao_data /mnt
[root@localhost admin]# service rpcbind status
rpcbind (pid  8192) is running...
[root@localhost admin]# /etc/init.d/rpcbind status
rpcbind (pid  8192) is running...

so it's a regression bug from 6.3 GA to 6.4.


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130116.3.0.el6

How reproducible:
100%
  
Steps to Reproduce:


Actual result:

Expect result:

Additional info:
Comment 3 Fabian Deutsch 2013-01-22 07:43:34 EST
rpcbind was dropped b/c of bug 794862.

But rpcbind seems to be needed also by the NFS client.

This patch re-adds the rpcbind package:
http://gerrit.ovirt.org/#/c/11277/

Tested as follows:
1. Install w patch
2. Configure Network (important)
3.
# mount -t nfs 1xx.xxx.xxx.xxx:/vol/S1/data /mnt
mount.nfs: access denied by server ...

4. Connection to server is established (even if the authentication fails)
Comment 10 Yaniv Kaul 2013-01-28 01:44:44 EST
*** Bug 869956 has been marked as a duplicate of this bug. ***
Comment 11 haiyang,dong 2013-01-29 00:35:08 EST
Test version:
rhev-hypervisor6-6.4-20130128.0.2
ovirt-node-2.5.0-17.el6
vdsm-4.10.2-1.2.el6
rhevm-3.1.0-43.el6

Test as follows:
1. Install rhev-h
2. Configure Network (important)
3.
[root@localhost admin]# service rpcbind status
rpcbind (pid  11362) is running...
[root@localhost admin]# mount -t nfs 10.66.90.115:/vol/S1/cshao_data /mnt
[root@localhost admin]# mount |grep /mnt
10.66.90.115:/vol/S1/cshao_data on /mnt type nfs (rw,addr=10.66.90.115)

Also try to register rhevh into rhevm si ,then NFS storage domains can be attached successfully.

So this bug has been fixed, change the status into "VERIFIED".
Comment 12 Tim Hildred 2013-02-12 03:22:21 EST
Almost a duplicate? 
https://bugzilla.redhat.com/show_bug.cgi?id=880099
Comment 13 Mike Burns 2013-02-25 08:07:50 EST
*** Bug 902230 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2013-02-28 11:47:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html
Comment 16 Mike Burns 2013-04-08 08:50:56 EDT
*** Bug 912933 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.