Bug 90286 - i810_audio does not support Intel 82801EB
i810_audio does not support Intel 82801EB
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-06 10:41 EDT by David Lowther
Modified: 2015-01-04 17:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 12:28:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lowther 2003-05-06 10:41:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
i810_audio does not support the Intel 82801EB ICH5. The system under test has 
an ICH5 and an ADI1981B codec. 

The PCI ID for the ICH5 is 0x24d5. 

Audio works correctly with the same kernel on another system that has the same 
codec, but on an ICH4, PCI ID 0x24c5.

Version-Release number of selected component (if applicable):
2.4.20-9smp

How reproducible:
Always

Steps to Reproduce:
1.Load kernel on system
2.Check audio
3.
    

Actual Results:  No sound, no soundcard detected.

Expected Results:  Sound.

Additional info:
Comment 1 Arjan van de Ven 2003-05-06 10:48:07 EDT
we tried adding ICH5 support last minute but it really didn't work and crashed
all over; it seems to not be just adding a PCI ID
Comment 2 Seth Vidal 2003-07-15 17:28:09 EDT
The dell dimension 4600 systems built in sound card is this one.
I tried adding the pci id but still no joy either. Though according to the dell
forum this is working on suse linux 8.2. Are they using alsa?

Comment 3 andrew m. boardman 2003-07-27 15:01:40 EDT
ICH5 support was added in 2.4.21.  (We have the same hardware, and Severn works
fine on it.)  Any chance of a 2.4.21 kernel release for Red Hat Linux 9?  The
relevant chipset is showing up in a *lot* of new hardware.
Comment 4 Marcin Pilipczuk 2003-11-01 06:06:31 EST
On my system (Motherboard i865) on Severn (with 2.4.22-1.2088.nptlsmp)
this sound card is recognised as 82801EB AC'97. But when trying
loading i810_audio module it reports errors similar to described by
the Reporter:

[root@localhost root]# insmod i810_audio
Using /lib/modules/2.4.22-1.2088.nptlsmp/kernel/drivers/sound/i810_audio.o
/lib/modules/2.4.22-1.2088.nptlsmp/kernel/drivers/sound/i810_audio.o:
unresolved symbol ac97_set_adc_rate_Rsmp_269f98e8
/lib/modules/2.4.22-1.2088.nptlsmp/kernel/drivers/sound/i810_audio.o:
unresolved symbol ac97_alloc_codec_Rsmp_98951e4d
/lib/modules/2.4.22-1.2088.nptlsmp/kernel/drivers/sound/i810_audio.o:
unresolved symbol ac97_set_dac_rate_Rsmp_d7cbe165
/lib/modules/2.4.22-1.2088.nptlsmp/kernel/drivers/sound/i810_audio.o:
unresolved symbol ac97_release_codec_Rsmp_ec27652f
/lib/modules/2.4.22-1.2088.nptlsmp/kernel/drivers/sound/i810_audio.o:
unresolved symbol ac97_probe_codec_Rsmp_9fc40528

Boot log presents the following 'failure' entries:
Oct 28 22:58:47 localhost firstboot:
/lib/modules/2.4.22-1.2088.nptlsmp/kernel/drivers/sound/i810_audio.o:
insmod /lib/modules/2.4.22-1.2088.nptlsmp/kernel/driv
ers/sound/i810_audio.o failed                                        
          Oct 28 22:58:47 localhost firstboot:
/lib/modules/2.4.22-1.2088.nptlsmp/kernel/d
rivers/sound/i810_audio.o: insmod i810_audio failed

Question: Is there any chance that official RH9.1 will support this
sound card?
Comment 5 Isaac Salsberg 2003-11-06 18:19:05 EST
I have the same audio card, and the module loads, however 
I can not get any sound from it.

The kernel version is: 2.4.20-20.9.

[root@vaio-desk init.d]# lsmod
Module                  Size  Used by    Not tainted
i810_audio             27624   0  (unused)
ac97_codec             14568   0  [i810_audio]
soundcore               6404   2  [i810_audio]
parport_pc             19076   1  (autoclean)


This bug seems related with bugs 92229 and 88586
Comment 6 Dave Jones 2003-11-18 09:57:22 EST
#4 : You can't just use the i810_audio module, you need the other
parts too, such as ac97_codec.o
Also, there won't be a Red Hat 9.1, instead there is Fedora Core 1.
The likelyhood of this appearing in a future RHL9 errata kernel is
undecided at this time. With the EOL in just a few months, it depends
how invasive the patch would end up being.  As noted earlier in this
bug, it isn't a case of just adding a PCI ID.
Comment 7 Jason Smith 2004-04-02 09:13:46 EST
Is this bug related to bug #109528 for RHEL-3?  That bug report was
opened almost 5 months ago and no one from RedHat has even commented
on it yet!  Will this sound card ever be supported by RedHat?
Comment 8 Dave Jones 2004-04-02 12:28:43 EST
Not in RHL9 no. For RHEL3, comment in the other bug.

Note You need to log in before you can comment on or make changes to this bug.