Bug 902996 - SELinux is preventing /usr/libexec/colord from 'read' accesses on the file cgroup.
SELinux is preventing /usr/libexec/colord from 'read' accesses on the file cg...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:17748ee9e6d20b7f39d1c1441d5...
:
: 903037 903038 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 16:58 EST by Raphos
Modified: 2013-02-07 21:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-07 21:22:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphos 2013-01-22 16:58:58 EST
Description of problem:
SELinux is preventing /usr/libexec/colord from 'read' accesses on the file cgroup.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que colord devrait être autorisé à accéder read sur cgroup file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep colord /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0
Target Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Objects                cgroup [ file ]
Source                        colord
Source Path                   /usr/libexec/colord
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           colord-0.1.28-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-71.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.7.2-204.fc18.x86_64 #1 SMP Wed
                              Jan 16 16:22:52 UTC 2013 x86_64 x86_64
Alert Count                   5
First Seen                    2013-01-21 21:29:17 CET
Last Seen                     2013-01-22 22:36:29 CET
Local ID                      1f82aa28-bb6b-47fc-9042-906e17b5daa8

Raw Audit Messages
type=AVC msg=audit(1358890589.462:314): avc:  denied  { read } for  pid=1244 comm="colord" name="cgroup" dev="proc" ino=24672 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=file


type=SYSCALL msg=audit(1358890589.462:314): arch=x86_64 syscall=open success=no exit=EACCES a0=826a80 a1=80000 a2=1b6 a3=238 items=0 ppid=1 pid=1244 auid=4294967295 uid=998 gid=997 euid=998 suid=998 fsuid=998 egid=997 sgid=997 fsgid=997 ses=4294967295 tty=(none) comm=colord exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0 key=(null)

Hash: colord,colord_t,cupsd_t,file,read

audit2allow

#============= colord_t ==============
allow colord_t cupsd_t:file read;

audit2allow -R

#============= colord_t ==============
allow colord_t cupsd_t:file read;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.7.2-204.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-01-23 03:48:37 EST
*** Bug 903038 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-01-23 03:54:51 EST
*** Bug 903037 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-01-23 03:57:55 EST
Fixed in selinux-policy-3.11.1-74.fc18.noarch
Comment 4 Pascal94 2013-01-23 06:53:10 EST
just started my computer

Package: (null)
OS Release: Fedora release 18 (Spherical Cow)
Comment 5 Fedora Update System 2013-01-31 08:17:28 EST
selinux-policy-3.11.1-74.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-74.fc18
Comment 6 Fedora Update System 2013-02-01 11:38:02 EST
Package selinux-policy-3.11.1-74.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-74.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1693/selinux-policy-3.11.1-74.fc18
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-02-07 21:22:31 EST
selinux-policy-3.11.1-74.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.