Bug 903038 - SELinux is preventing /usr/libexec/colord from 'getattr' accesses on the file /proc/<pid>/cgroup.
SELinux is preventing /usr/libexec/colord from 'getattr' accesses on the file...
Status: CLOSED DUPLICATE of bug 902996
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4879d9cdd8aa8e94b68e3792fdc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-01-22 19:51 EST by fx105548d
Modified: 2013-01-23 03:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-23 03:48:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fx105548d 2013-01-22 19:51:53 EST
Description of problem:
SELinux is preventing /usr/libexec/colord from 'getattr' accesses on the file /proc/<pid>/cgroup.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that colord should be allowed getattr access on the cgroup file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep colord /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:colord_t:s0
Target Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Objects                /proc/<pid>/cgroup [ file ]
Source                        colord
Source Path                   /usr/libexec/colord
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           colord-0.1.28-1.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-71.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.7.2-204.fc18.x86_64 #1 SMP Wed
                              Jan 16 16:22:52 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-01-22 11:51:35 WET
Last Seen                     2013-01-23 00:49:48 WET
Local ID                      2d4f8bd4-86f2-47e8-84ef-94992036412c

Raw Audit Messages
type=AVC msg=audit(1358902188.812:370): avc:  denied  { getattr } for  pid=1702 comm="colord" path="/proc/1698/cgroup" dev="proc" ino=39460 scontext=system_u:system_r:colord_t:s0 tcontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tclass=file


type=SYSCALL msg=audit(1358902188.812:370): arch=x86_64 syscall=fstat success=yes exit=0 a0=f a1=7fff7bfdb170 a2=7fff7bfdb170 a3=0 items=0 ppid=1 pid=1702 auid=4294967295 uid=998 gid=997 euid=998 suid=998 fsuid=998 egid=997 sgid=997 fsgid=997 ses=4294967295 tty=(none) comm=colord exe=/usr/libexec/colord subj=system_u:system_r:colord_t:s0 key=(null)

Hash: colord,colord_t,cupsd_t,file,getattr

audit2allow

#============= colord_t ==============
allow colord_t cupsd_t:file getattr;

audit2allow -R

#============= colord_t ==============
allow colord_t cupsd_t:file getattr;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.7.2-204.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-01-23 03:48:37 EST

*** This bug has been marked as a duplicate of bug 902996 ***

Note You need to log in before you can comment on or make changes to this bug.