Bug 903668 - Firmware fails to load on new kernels. Intel Wireless adaptor is not working.
Summary: Firmware fails to load on new kernels. Intel Wireless adaptor is not working.
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-01-24 14:39 UTC by cbindahouse
Modified: 2017-03-09 17:47 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 980055 (view as bug list)
Environment:
Last Closed: 2014-01-24 18:44:00 UTC
Type: Bug


Attachments (Terms of Use)
dmesg output on Fedora 18 (17.91 KB, text/plain)
2013-01-24 15:23 UTC, cbindahouse
no flags Details
dmesg output with verbose debugging enabled (174.78 KB, text/plain)
2013-08-06 15:53 UTC, cbindahouse
no flags Details
output of "lspci -vnn" (16.15 KB, text/plain)
2013-08-06 15:54 UTC, cbindahouse
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Intel Wireless Bugzilla 2314 0 None None None Never

Description cbindahouse 2013-01-24 14:39:55 UTC
Description of problem:
The firmware fails to load on boot, which means that the Wireless adaptor is marked as 'unavailable' and thus unusable.

Reported here as well http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2314
However, this was reported a year and a half ago and has still not been fixed.

Version-Release number of selected component (if applicable):
Intel Centrino-N 1000 Wireless Adaptor.

How reproducible:
Every time

Steps to Reproduce:
1. Boot the laptop
2. Error messages as wireless fails to intialise
  
Actual results:
Wireless does not work.

Expected results:
Wireless should be working. Works on Windows (and older kernel versions).

Additional info:
This used to work before newer kernel versions (around when the 3.0.0-1 kernel came in) and has not worked since. A previous workaround was to use the old v3 code, although iwlagn is not present in Fedora 18 and therefore this workaround does not work currently. Disabling the 'N' part was also suggested although this hasn't worked for me.

Comment 1 John W. Linville 2013-01-24 14:57:53 UTC
The driver name changed from iwlagn to iwlwifi.  I'm not sure what workaround you mean, but maybe that helps?

Anyway, I would need to see the output of dmesg to have any idea what the problem is with the firmware loading.  Please run 'dmesg' and attach the output from that to this bug...thanks!

Comment 2 cbindahouse 2013-01-24 15:23:19 UTC
Created attachment 686825 [details]
dmesg output on Fedora 18

Comment 3 cbindahouse 2013-01-24 15:25:27 UTC
Ok so the workaround of reverting to the old v3 code does still work, by doing something like 

sudo mv /lib/firmware/iwlwifi-1000-5.ucode /lib/firmware/iwlwifi-1000-5.ucode.backup

However, this has been a temporary fix for the past nearly year and a half (see http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2314 which I reported on the Intel bugzilla).

Comment 4 John W. Linville 2013-01-24 16:33:15 UTC
Firmware errors on load with iwlwifi-1000-5...Johannes, should we consider changing the driver to only ask for version 3?

Comment 5 cbindahouse 2013-07-01 11:46:37 UTC
Is this a fix? V3 is not included by default any more, it has to be manually downloaded from the Intel website.

Comment 6 Stanislaw Gruszka 2013-07-16 09:45:26 UTC
Either firmware should be fixed or driver should be fixed to work with the new firmware. Does the problem still ocures on lates kernel i.e. 3.9 ?

Comment 7 cbindahouse 2013-08-01 21:38:12 UTC
Yep, still broken on 3.10.

Comment 8 Stanislaw Gruszka 2013-08-02 07:42:17 UTC
Then, please load module with verbose debugging enabled, i.e.

modprobe -r iwldvm
modprobe iwlwifi debug=47ffffff

and attach dmesg output.

Comment 9 Stanislaw Gruszka 2013-08-02 07:43:21 UTC
(In reply to Stanislaw Gruszka from comment #8)
> modprobe iwlwifi debug=47ffffff
It should be:
modprobe iwlwifi debug=0x47ffffff

Comment 10 Stanislaw Gruszka 2013-08-02 07:45:24 UTC
Please also attach output of "lspci -vnn"

Comment 11 cbindahouse 2013-08-06 15:53:58 UTC
Created attachment 783393 [details]
dmesg output with verbose debugging enabled

Comment 12 cbindahouse 2013-08-06 15:54:27 UTC
Created attachment 783394 [details]
output of "lspci -vnn"

Comment 13 Stanislaw Gruszka 2013-08-07 11:41:36 UTC
Unfortunately dmesg buffer wrapped out so reason of microcode error at start is not visible. Please do the following to grab debug messages:

Add this line in /etc/rsyslog.conf: 
kern.*                                                  /var/log/kernel

Restart rsyslog:
# systemctl restart rsyslog.service

Unload module:
# modprobe -r iwldvm

Grab messages:
# echo > /var/log/kernel
# modprobe iwlwifi debug=0x0x47ffffff

Again unload module:
# modprobe -r iwldvm

And attach /var/log/kernel file here.

Comment 14 Stanislaw Gruszka 2013-10-15 13:54:08 UTC
Could you please provide information requested in comment 13 ?

Comment 15 Justin M. Forbes 2013-10-18 21:20:04 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.

Comment 16 Stanislaw Gruszka 2013-11-20 10:16:52 UTC
We need logs requested in comment 13 ?

Comment 17 Stanislaw Gruszka 2014-01-24 18:44:00 UTC
closing due to lack of response


Note You need to log in before you can comment on or make changes to this bug.