Bug 980055 - Firmware fails to load on new kernels. Intel Wireless adaptor is not working.
Summary: Firmware fails to load on new kernels. Intel Wireless adaptor is not working.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 19
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-01 10:23 UTC by Dietrich
Modified: 2013-07-01 11:14 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 903668
Environment:
Last Closed: 2013-07-01 11:14:33 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Intel Wireless Bugzilla 2314 0 None None None Never

Description Dietrich 2013-07-01 10:23:12 UTC
+++ This bug was initially created as a clone of Bug #903668 +++

Cloned because the suggested workaround (rename iwlwifi*-5.ucode) does not seem to have an effect with the laptop I am using and the version of Fedora is no longer 18 but now 19.

The bug description still applies.

Hardware info I get:

$ lspci
[...]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
03:00.0 System peripheral: Ricoh Co Ltd MMC/SD Host Controller (rev 07)
08:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]

The dmesg of reloading the iwlwifi  module.

$ sudo rmmod iwlwifi
$ sudo dmesg -c
[...]
$ sudo modprobe iwlwifi
$ dmesg
[ 1452.960160] iwlwifi: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:d
[ 1452.960164] iwlwifi: Copyright(c) 2003-2012 Intel Corporation
[ 1452.960302] iwlwifi 0000:08:00.0: >pci_resource_len = 0x00002000
[ 1452.960304] iwlwifi 0000:08:00.0: >pci_resource_base = ffffc90005824000
[ 1452.960306] iwlwifi 0000:08:00.0: >HW Revision ID = 0x0
[ 1452.960581] iwlwifi 0000:08:00.0: >irq 43 for MSI/MSI-X
[ 1513.167213] iwlwifi 0000:08:00.0: >request for firmware file 'iwlwifi-1000-5.ucode' failed.
[ 1574.284042] iwlwifi 0000:08:00.0: >request for firmware file 'iwlwifi-1000-4.ucode' failed.
[ 1635.145314] iwlwifi 0000:08:00.0: >request for firmware file 'iwlwifi-1000-3.ucode' failed.
[ 1696.006183] iwlwifi 0000:08:00.0: >request for firmware file 'iwlwifi-1000-2.ucode' failed.
[ 1756.995128] iwlwifi 0000:08:00.0: >request for firmware file 'iwlwifi-1000-1.ucode' failed.
[ 1756.995132] iwlwifi 0000:08:00.0: >no suitable firmware found!

Note how slow the firmwarerequests appear!

The firmware-files exist in /usr/lib/firmware aswell as via symlink in /lib/firmware:

$ ls -l /usr/lib/firmware/iwlwifi-1000* /lib/firmware/iwlwifi-1000*
-rw-r--r--. 1 root root 335056 18. Apr 16:57 /lib/firmware/iwlwifi-1000-3.ucode
-rw-r--r--. 1 root root 337520 18. Apr 16:57 /lib/firmware/iwlwifi-1000-5.ucode
-rw-r--r--. 1 root root 335056 18. Apr 16:57 /usr/lib/firmware/iwlwifi-1000-3.ucode
-rw-r--r--. 1 root root 337520 18. Apr 16:57 /usr/lib/firmware/iwlwifi-1000-5.ucode

Finally the lshw output related to network:

$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: RTL8111/8168 PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: p1p1
       version: 06
       serial: f0:de:f1:a6:24:ae
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.178.20 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:42 ioport:4000(size=256) memory:d0404000-d0404fff memory:d0400000-d0403fff
  *-network UNCLAIMED
       description: Network controller
       product: Centrino Wireless-N 1000 [Condor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:08:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:d1d00000-d1d01fff



Description of problem:
The firmware fails to load on boot, which means that the Wireless adaptor is marked as 'unavailable' and thus unusable.

Reported here as well http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2314
However, this was reported a year and a half ago and has still not been fixed.

Version-Release number of selected component (if applicable):
Intel Centrino-N 1000 Wireless Adaptor.

How reproducible:
Every time

Steps to Reproduce:
1. Boot the laptop
2. Error messages as wireless fails to intialise
  
Actual results:
Wireless does not work.

Expected results:
Wireless should be working. Works on Windows (and older kernel versions).

Additional info:
This used to work before newer kernel versions (around when the 3.0.0-1 kernel came in) and has not worked since. A previous workaround was to use the old v3 code, although iwlagn is not present in Fedora 18 and therefore this workaround does not work currently. Disabling the 'N' part was also suggested although this hasn't worked for me.

--- Additional comment from John W. Linville on 2013-01-24 09:57:53 EST ---

The driver name changed from iwlagn to iwlwifi.  I'm not sure what workaround you mean, but maybe that helps?

Anyway, I would need to see the output of dmesg to have any idea what the problem is with the firmware loading.  Please run 'dmesg' and attach the output from that to this bug...thanks!

--- Additional comment from  on 2013-01-24 10:23:19 EST ---



--- Additional comment from  on 2013-01-24 10:25:27 EST ---

Ok so the workaround of reverting to the old v3 code does still work, by doing something like 

sudo mv /lib/firmware/iwlwifi-1000-5.ucode /lib/firmware/iwlwifi-1000-5.ucode.backup

However, this has been a temporary fix for the past nearly year and a half (see http://bugzilla.intellinuxwireless.org/show_bug.cgi?id=2314 which I reported on the Intel bugzilla).

--- Additional comment from John W. Linville on 2013-01-24 11:33:15 EST ---

Firmware errors on load with iwlwifi-1000-5...Johannes, should we consider changing the driver to only ask for version 3?

Comment 1 Dietrich 2013-07-01 11:14:33 UTC
Sorry for spamming the bugtracker.

The problem was a misconfiguration of grub2 so that only a very old kernel fromfedora 17 was booted. After reinstalling grub to the mbr, recreating the grub.cfg and booting the f19 kernel everything works as expected.

thanks anyways :P

enaut


Note You need to log in before you can comment on or make changes to this bug.